Bug 1000350 - Invakid error handling in initialization of DroolsEventProcessor
Invakid error handling in initialization of DroolsEventProcessor
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Gary Brown
Jiri Pechanec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 05:11 EDT by Jiri Pechanec
Modified: 2014-07-02 05:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-258 Major Closed DroolsEventProcessor should fail deployment if rule not found 2014-07-02 05:19:39 EDT

  None (edit)
Description Jiri Pechanec 2013-08-23 05:11:31 EDT
When DroolsEventProcessor is incorrectly configured (wron rulename) it thorws NPE during EPN execution.

The problem is in createSession method. When rules loading fails, an exception is logged but _session is initatied to null and then silently ignored - see System.out.println.

Application should not be deployed at all under these circumstances
Comment 1 JBoss JIRA Server 2013-09-02 07:29:44 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-258 to Resolved
Comment 5 Jiri Pechanec 2013-10-16 07:47:15 EDT
Verified in ER4
Comment 6 JBoss JIRA Server 2014-07-02 05:19:39 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-258 to Closed

Note You need to log in before you can comment on or make changes to this bug.