Bug 1000371 - Jboss installation / rpm seem to be broken (Error on wss4j.jar)
Summary: Jboss installation / rpm seem to be broken (Error on wss4j.jar)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jboss-as
Version: 19
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Marek Goldmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-23 10:03 UTC by Sebastien Pasche
Modified: 2013-09-14 02:41 UTC (History)
4 users (show)

Fixed In Version: jboss-as-7.1.1-21.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-14 02:41:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Sebastien Pasche 2013-08-23 10:03:58 UTC
Description of problem:

JBoss can't start properly due to complaint about wss4j.jar component of apache.ws.sercury module

Version-Release number of selected component (if applicable):

jboss-as-7.1.1-20.fc19.noarch
wss4j-1.6.9-1.fc19.noarch

How reproducible:

Just install jboss-as and start it

Steps to Reproduce:
1. yum install jboss-as
2. systemctl start jboss-as.service
3.

Actual results:

exception : 

http://paste.fedoraproject.org/34226/77251524/

And for information all files seem to be present

ERROR in server.log : 


11:07:52,251 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 46) JBAS014612: Operation ("add") failed - address: ([("subsystem" => "webservices")]): java.lang.RuntimeException: org.jboss.modules.ModuleLoadException: Error loading module from /usr/share/jboss-as/modules/org/apache/ws/security/main/module.xml
	at org.jboss.as.webservices.util.ModuleClassLoaderProvider.getServerIntegrationClassLoader(ModuleClassLoaderProvider.java:56)
	at org.jboss.as.webservices.deployers.deployment.DeploymentAspectsProvider.getSortedDeploymentAspects(DeploymentAspectsProvider.java:53)
	at org.jboss.as.webservices.dmr.WSDeploymentActivator.addDeploymentProcessors(WSDeploymentActivator.java:77)
	at org.jboss.as.webservices.dmr.WSDeploymentActivator.activate(WSDeploymentActivator.java:71)
	at org.jboss.as.webservices.dmr.WSSubsystemAdd$1.execute(WSSubsystemAdd.java:118)
	at org.jboss.as.server.AbstractDeploymentChainStep.execute(AbstractDeploymentChainStep.java:45)
	at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:385) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
	at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:272) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
	at org.jboss.as.controller.AbstractOperationContext.completeStep(AbstractOperationContext.java:200) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
	at org.jboss.as.controller.ParallelBootOperationStepHandler$ParallelBootTask.run(ParallelBootOperationStepHandler.java:311) [jboss-as-controller-7.1.1.Final.jar:7.1.1.Final]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_25]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.0.0.GA]
Caused by: org.jboss.modules.ModuleLoadException: Error loading module from /usr/share/jboss-as/modules/org/apache/ws/security/main/module.xml
	at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:292) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:242) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.LocalModuleLoader.parseModuleInfoFile(LocalModuleLoader.java:138) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:122) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.Module.addPaths(Module.java:841) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.Module.link(Module.java:1196) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.Module.relinkIfNecessary(Module.java:1225) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.as.webservices.util.ModuleClassLoaderProvider.getServerIntegrationClassLoader(ModuleClassLoaderProvider.java:53)
	... 13 more
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[31,42]
Message: Failed to add resource root 'wss4j.jar' at path 'wss4j.jar'
	at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548) [jboss-modules.jar:1.1.1.GA]
	at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287) [jboss-modules.jar:1.1.1.GA]
	... 24 more

11:07:52,393 INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-7) Starting Coyote HTTP/1.1 on http--0.0.0.0-8080


Information about file
         
[root@mgbsy7a19 standalone]# ll /usr/share/jboss-as/modules/org/apache/ws/security/main/
total 4
-rw-r--r--. 1 root root 1703 Jun 17 22:07 module.xml
lrwxrwxrwx. 1 root root   25 Aug 20 10:49 wss4j.jar -> /usr/share/java/wss4j.jar
[root@mgbsy7a19 standalone]# ll /usr/share/java/wss*
total 432
-rw-r--r--. 1 root root 438443 Aug  1 11:44 wss4j.jar


Expected results:


Additional info:

Comment 1 Tom Antony 2013-08-26 11:42:49 UTC
Symbolic link for wss4j.jar is wrong, it should point to /usr/share/java/wss4j/wss4j.jar (as for wss4j 1.6.10 1.fc19).

Comment 2 Marek Goldmann 2013-08-30 08:37:29 UTC
Thanks for the info, I'll fix it ASAP. I couldn't make it earlier since I was on vacations.

Comment 3 Fedora Update System 2013-09-05 09:50:04 UTC
jboss-as-7.1.1-21.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/jboss-as-7.1.1-21.fc19

Comment 4 Sebastien Pasche 2013-09-05 11:07:20 UTC
Working fine thx !

Comment 5 Fedora Update System 2013-09-06 05:17:42 UTC
Package jboss-as-7.1.1-21.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jboss-as-7.1.1-21.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15909/jboss-as-7.1.1-21.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-09-14 02:41:24 UTC
jboss-as-7.1.1-21.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.