Bug 1000381 - "jboss-cli.sh" could not be found in jbosseap-6.0 gear
"jboss-cli.sh" could not be found in jbosseap-6.0 gear
Status: CLOSED NEXTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.1
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 06:45 EDT by Ma xiaoqiang
Modified: 2016-07-03 20:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 08:45:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-08-23 06:45:00 EDT
Description of problem:
"jboss-cli.sh" could not be found in  jbosseap-6.0 gear, but online devenv could.

Version-Release number of selected component (if applicable):
1.2/2013-08-22.2 puddle

How reproducible:
always

Steps to Reproduce:
1.create a jbosseap-6.0 app
2.login to gear, run the following command:
> jboss-cli.sh -c --controller=$OPENSHIFT_JBOSSEAP_IP:9999

Actual results:
bash: jboss-cli.sh: command not found

Expected results:
"jboss-cli.sh" shoud be found, and executed successfully.

Additional info:
online:
> jboss-cli.sh -c --controller=$OPENSHIFT_JBOSSEAP_IP:9999
[standalone@127.0.251.1:9999 /] 
> which jboss-cli.sh
/var/lib/openshift/52173b6ee6498c096b000001/jbosseap/bin/tools/jboss-cli.sh
Comment 2 Jason DeTiberus 2013-08-23 08:45:28 EDT
For OSE 1.2 you can use the following:
/usr/share/jbossas/bin/jboss-cli.sh -c --controller=$OPENSHIFT_JBOSSEAP_IP:9999

The jboss-cli.sh helper script also exports JAVA_OPTS="-Djboss.management.client_socket_bind_address=$OPENSHIFT_JBOSSEAP_IP", since the jboss cli tries to bind to a localhost port by default and that is blocked by SELinux policy in Online (but not in Enterprise).

That said, we will inherit the jboss-cli.sh helper script with the 2.0 rebase.

Note You need to log in before you can comment on or make changes to this bug.