Bug 1000384 - NPE when ksession is serialized with facts logically inserted
NPE when ksession is serialized with facts logically inserted
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
5.x.x
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Edson Tirelli
Tomas Schlosser
:
Depends On:
Blocks: 1000385
  Show dependency treegraph
 
Reported: 2013-08-23 06:51 EDT by Toshiya Kobayashi
Modified: 2014-08-06 16:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1000385 (view as bug list)
Environment:
Last Closed: 2014-08-06 16:15:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DROOLS-236 Major Closed NPE when ksession is serialized with facts logically inserted 2013-12-13 10:59:05 EST

  None (edit)
Description Toshiya Kobayashi 2013-08-23 06:51:20 EDT
Description of problem:

Platform BZ for https://issues.jboss.org/browse/DROOLS-236

Steps to Reproduce:
1. See DROOLS-236 and test case in the pull request


Actual results:

Throws NullPointerException

Expected results:

Rule is executed.
Comment 1 JBoss JIRA Server 2013-08-23 19:58:45 EDT
Davide Sottara <dsotty@gmail.com> made a comment on jira DROOLS-236

The problem is in the ProtoBuf, Edson is fixing it even now. 
Affects version 5.x as well
Comment 3 JBoss JIRA Server 2013-08-24 14:56:52 EDT
Edson Tirelli <ed.tirelli@gmail.com> made a comment on jira DROOLS-236

Fixed in 6.0.x and master. Will backport to 5.x. Thanks for the test case and investigating the problem.
Comment 4 JBoss JIRA Server 2013-08-24 14:57:11 EDT
Edson Tirelli <ed.tirelli@gmail.com> updated the status of jira DROOLS-236 to Closed
Comment 8 Tomas Schlosser 2013-10-14 08:57:01 EDT
Verified in BRMS.6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.