Bug 1000389 - sudo: internal error, tried to erealloc3(0) with sssd backend
sudo: internal error, tried to erealloc3(0) with sssd backend
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sudo (Show other bugs)
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Daniel Kopeček
David Spurek
Depends On:
Blocks: 1006611
  Show dependency treegraph
Reported: 2013-08-23 07:01 EDT by Pavel Březina
Modified: 2015-03-02 00:27 EST (History)
3 users (show)

See Also:
Fixed In Version: sudo-1.8.6p7-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-13 09:22:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
proposed patch (503 bytes, patch)
2013-08-23 07:02 EDT, Pavel Březina
no flags Details | Diff

  None (edit)
Description Pavel Březina 2013-08-23 07:01:49 EDT
Description of problem:
When sssd returns rules to sudo and all rules are filtered out, sudo calls erealloc3(0).

How reproducible:

Steps to Reproduce:
1. Configure sudo to use sssd
2. Create a sudo rule with:
sudoUser: tuser
sudoCommand: ALL
but without sudoHost attibute
3. Run sudo -l as tuser

Actual results:
$ sudo -l
sudo: internal error, tried to erealloc3(0)

Expected results:
$ sudo -l
User tuser is not allowed to run sudo on client.

Additional info:
Patch attached.
Comment 1 Pavel Březina 2013-08-23 07:02:58 EDT
Created attachment 789555 [details]
proposed patch
Comment 5 Ludek Smid 2014-06-13 09:22:51 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.