Bug 1000394 - Socket binding can be set only for standalone.xml
Socket binding can be set only for standalone.xml
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ---
: EAP 6.2.0
Assigned To: Thomas Hauser
Petr Kremensky
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 07:17 EDT by Petr Kremensky
Modified: 2017-10-09 20:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-09 04:43:54 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-08-23 07:17:04 EDT
Using custom socket binding during installation I am able to set custom sockets for standalone and domain. While for domain there are screens for every profile, for standalone there is only one screen which allow user to customize ports only for standalone.xml configuration file. Other standalone configuration files must be edited manually.

 - Reproduce:
Choose to configure ports for standalone during installation
Change eg. ajp port to 8989
Finish installation

[jboss-eap-6.1/standalone/configuration]$ grep -r "socket-binding name=\"ajp\"" .
./standalone-full.xml:        <socket-binding name="ajp" port="8009"/>
./standalone.xml:        <socket-binding name="ajp" port="${asd:8989}"/>
./standalone-full-ha.xml:        <socket-binding name="ajp" port="8009"/>
./standalone-osgi.xml:        <socket-binding name="ajp" port="8009"/>
./standalone-ha.xml:        <socket-binding name="ajp" port="8009"/>

We may add also separate screens for standalone profiles ports.
Comment 1 Thomas Hauser 2013-08-23 09:53:18 EDT
This feature will be available for 6.2. The new feature was not cleared for 6.1.x, unfortunately, so we're stuck with only modifying standalone.xml or domain.xml. Because of this, I am closing this BZ with NEXTRELEASE; let me know if this is incorrect.
Comment 3 Petr Kremensky 2014-01-09 04:43:54 EST
This feature is available in 6.2 installer.
Re-closing.

Note You need to log in before you can comment on or make changes to this bug.