Bug 1000404 - CheckBoxNodes on Pack selection screen are grey (like disabled) after unchecking
CheckBoxNodes on Pack selection screen are grey (like disabled) after unchecking
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity low
: ER1
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 07:46 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:12:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-08-23 07:46:21 EDT
Description of problem:
CheckBoxNodes on Pack selection screen are acting in strange way. Try to uncheck Eap Natives, Next -> Previous, Eap Natives branch is grey (like disabled, but it isn't). Also try to uncheck one of Natives option, Next -> Previous, option is checked again and is grey.
Comment 1 Francisco Canas 2013-08-23 13:33:47 EDT
I have applied the fix for this issue from the 6.2 installer branch.

- The state of checked/unchecked packs is now properly remembered when you navigate to a different panel and then back again. 
- The packs that a user is allowed to add/remove are no longer grayed out. If a pack is grayed out, it is either required, or must be configured in a different panel (like quickstarts). 

See this commit for details:

http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=3bef83788130f86bfae6a222007245826665f13f
Comment 2 Petr Kremensky 2013-08-27 03:45:34 EDT
Hi,
there will be no ER8. Changing target release to EAP 6.2.
Comment 3 Petr Kremensky 2013-09-13 06:26:28 EDT
Hi, please move BZs to ON_QA once the issue is fixed and target release is available so I can verify it. Thanks
Comment 4 Petr Kremensky 2013-09-13 09:34:17 EDT
Verified on EAP 6.2.0 ER1

Note You need to log in before you can comment on or make changes to this bug.