Bug 1000484 - katello-configure did not start required katello jobs
katello-configure did not start required katello jobs
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-23 10:01 EDT by sthirugn@redhat.com
Modified: 2015-06-22 23:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:21:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2013-08-23 10:01:48 EDT
Description of problem:
katello-configure did not start required katello jobs

Version-Release number of selected component (if applicable):
SAM 1.3 Snap 3 errata compose - 
http://download.lab.bos.redhat.com/devel/candidate-trees/SAM/SAM-1.3.0-RHEL-6-20130823.0/compose/SAM/x86_64/os/

How reproducible:
Always

Steps to Reproduce:
1. Install SAM 1.3 from the errata compose mentioned above
2. Run katello-configure

Actual results:
katello-configure ran successfully but katello job, delayed_job and delayed_job_monitor processes did not start

# katello-service status
tomcat6 (pid 29580) is running...[  OK  ]
httpd (pid  29853) is running...
thumbslug (pid  29786) is running...
elasticsearch (pid  28929) is running...
katello is not running.
delayed_job is not running.
delayed_job_monitor is not running.


Expected results:
katello job

Additional info:
katello-configure -> main.log

<SNIP>
130823-09:33:47 Debug: /Stage[main]/Katello::Config/Exec[katello_db_printenv]: The container Class[Katello::Config] will propagate my refresh event
130823-09:33:47 Error: Could not find command '/usr/bin/ruby193-rake'
130823-09:33:47 Error: /Stage[main]/Katello::Config/Exec[katello_migrate_db]/returns: change from notrun to 0 failed: Could not find command '/usr/bin/ruby193-rake'
130823-09:33:47 Notice: /Stage[main]/Katello::Config/Exec[katello_seed_db]: Dependency Exec[katello_migrate_db] has failures: true
130823-09:33:47 Warning: /Stage[main]/Katello::Config/Exec[katello_seed_db]: Skipping because of failed dependencies
130823-09:33:47 Debug: Class[Katello::Config]: The container Stage[main] will propagate my refresh event
130823-09:33:47 Notice: /Stage[main]/Katello::Service/Service[katello]: Dependency Exec[katello_migrate_db] has failures: true
130823-09:33:47 Warning: /Stage[main]/Katello::Service/Service[katello]: Skipping because of failed dependencies
130823-09:33:47 Notice: /Stage[main]/Apache2/Exec[reload-apache2]: Dependency Exec[katello_migrate_db] has failures: true
130823-09:33:47 Warning: /Stage[main]/Apache2/Exec[reload-apache2]: Skipping because of failed dependencies
130823-09:33:47 Notice: /Stage[main]/Katello::Service/Service[katello-jobs]: Dependency Exec[katello_migrate_db] has failures: true
130823-09:33:47 Warning: /Stage[main]/Katello::Service/Service[katello-jobs]: Skipping because of failed dependencies
130823-09:33:47 Debug: Finishing transaction 22419760
130823-09:33:47 Debug: Storing state
130823-09:33:47 Debug: Stored state in 0.02 seconds
130823-09:33:47 Notice: Finished catalog run in 5.77 seconds
130823-09:33:47 Debug: Using settings: adding file resource 'rrddir': 'File[/var/lib/puppet/rrd]{:path=>"/var/lib/puppet/rrd", :mode=>"750", :owner=>"puppet", :group=>"puppet", :ensure=>:directory, :loglevel=>:debug, :links=>:follow, :backup=>false}'
130823-09:33:47 Debug: /File[/var/lib/puppet/rrd]/seluser: Found seluser default 'system_u' for /var/lib/puppet/rrd
130823-09:33:47 Debug: /File[/var/lib/puppet/rrd]/selrole: Found selrole default 'object_r' for /var/lib/puppet/rrd
130823-09:33:47 Debug: /File[/var/lib/puppet/rrd]/seltype: Found seltype default 'puppet_var_lib_t' for /var/lib/puppet/rrd
130823-09:33:47 Debug: /File[/var/lib/puppet/rrd]/selrange: Found selrange default 's0' for /var/lib/puppet/rrd
130823-09:33:47 Debug: Finishing transaction 25081240
130823-09:33:47 Debug: Received report to process from ibm-x3550m3-09.lab.eng.brq.redhat.com
130823-09:33:47 Debug: Processing report from ibm-x3550m3-09.lab.eng.brq.redhat.com with processor Puppet::Reports::Store

<SNIP>
Comment 1 sthirugn@redhat.com 2013-08-26 13:52:52 EDT
Reinstalled with the new SAM 1.3 errata and it worked fine.

* candlepin-0.8.21-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.21-1.el6sam.noarch
* candlepin-tomcat6-0.8.21-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-8.el6sat.noarch
* katello-cli-common-1.4.3-8.el6sat.noarch
* katello-common-1.4.3-9.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-9.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-9.el6sam_splice.noarch
* katello-headpin-1.4.3-9.el6sam_splice.noarch
* katello-headpin-all-1.4.3-9.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 3 errata-xmlrpc 2013-10-01 07:21:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.