Bug 1000504 - wrong console font mappings
wrong console font mappings
Status: CLOSED DUPLICATE of bug 970030
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 10:31 EDT by Karel Volný
Modified: 2013-09-29 14:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 14:04:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-08-23 10:31:31 EDT
Description of problem:
Despite great efforts to fix unicode problems related to F19 release name, utf-8 still fails, wrong characters are displayed.

Version-Release number of selected component (if applicable):
systemd-204-9.fc19

How reproducible:
always

Steps to Reproduce:
1. Install Fedora 19 in Czech language, for example.
2. Try to work in text console.
3. Try to use some nondefault font like Terminus (install terminus-fonts-console, set FONT="ter-v16n" in vconsole.conf and on kernel commandline, dracut -f, reboot)

Actual results:
2. instead of the apostrophe in "Schrödinger's cat" which is not exactly apostrophe a square is displayed
many czech characters (especially with carons) are mangled; "ý" is replaced with "y", "Á" with "A" etc.
3. everything is much worse; in addition to the abovementioned substitutions multiple characters (all of "ěĚšŠčČřŘžŽůŮňŇťŤ" to name) are replaced with "Ł"

Expected results:
all characters displayed properly - I'm using the abovementioned Terminus variant ter-v16n on a Gentoo system and all Czech characters work perfectly there

Additional info:
# localectl status
   System Locale: LANG=cs_CZ.UTF-8
       VC Keymap: cz-lat2
      X11 Layout: cz
     X11 Variant: qwerty
Comment 1 Kevin Kofler 2013-09-13 07:06:27 EDT
> 2. instead of the apostrophe in "Schrödinger's cat" which is not exactly
> apostrophe a square is displayed

I'm also seeing this here.

/etc/vconsole.conf:
FONT=latarcyrheb-sun16
KEYMAP=de

/etc/locale.conf:
LANG=de_AT.UTF-8

(and no kernel parameters overriding those settings, grub2-mkconfig no longer writes those).
Comment 2 Kevin Kofler 2013-09-13 07:11:56 EDT
(The keymap is also ignored, I get a US keyboard on the consoles!)
Comment 3 Kevin Kofler 2013-09-14 12:44:24 EDT
It looks like this is dracut's fault: dracut just does not include vconsole.conf and locale.conf in the initramfs at all!

After adding:
install_items+=" /etc/vconsole.conf /etc/locale.conf "
to /etc/dracut.conf, I get bug #970030 instead. But the keymap is still the US one.
Comment 4 Kevin Kofler 2013-09-14 13:21:38 EDT
> But the keymap is still the US one.

Nevermind, I had just "de" set rather than "de-latin1", and it looks like de is a mix between de-latin1 and us (it has the US key assignments where the umlauts should be).

So, to sum up, I see 2 issues:
1. dracut not installing vconsole.conf in the initramfs by default and
2. bug #970030 or something with similar symptoms (sounds like the result of Karel Volný's step 3 in the original post of this bug).
Comment 5 Lennart Poettering 2013-09-29 14:04:33 EDT

*** This bug has been marked as a duplicate of bug 970030 ***

Note You need to log in before you can comment on or make changes to this bug.