Bug 1000519 - (CVE-2013-2890) CVE-2013-2890 Kernel: HID: Sony heap overflow flaw
CVE-2013-2890 Kernel: HID: Sony heap overflow flaw
Status: CLOSED NOTABUG
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20130829,repor...
: Security
Depends On:
Blocks: 1000506
  Show dependency treegraph
 
Reported: 2013-08-23 10:49 EDT by Prasad J Pandit
Modified: 2015-07-31 07:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-10 04:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad J Pandit 2013-08-23 10:49:53 EDT
Linux kernel built with the Human Interface Device bus(CONFIG_HID) along with
the Sony PS3 controller driver(CONFIG_HID_SONY) support, is vulnerable to a
heap overflow flaw. It could occur when an HID device sends malicious output
report to the kernel driver.

A local user with physical access to the system could use this flaw to crash
the kernel resulting in DoS or potential privilege escalation to gain root
access via arbitrary code execution.
Comment 1 Prasad J Pandit 2013-08-23 10:51:30 EDT
Statement:

This issue does not affect the versions of the kernel package as shipped with Red Hat Enterprise Linux 5, 6 and Red Hat Enterprise MRG 2.

Note You need to log in before you can comment on or make changes to this bug.