Bug 1000522 - Conga does not disable scsi_reserve service even if it is enabled by it
Conga does not disable scsi_reserve service even if it is enabled by it
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.10
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On: 887170
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 10:55 EDT by Jan Pokorný
Modified: 2013-08-24 16:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 887170
Environment:
Last Closed: 2013-08-24 16:02:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-08-23 10:55:23 EDT
+++ This bug was initially created as a clone of Bug #887170 +++

As per [bug 887170 comment 11]

> Adding the fourth node virt-159 into the cluster set the service startup
> configuration as follows:
> [root@virt-159 ~]# chkconfig --list | egrep "rgmanager|cman|clvmd|scsi_reserve"
> clvmd          	0:off	1:off	2:on	3:on	4:on	5:on	6:off
> cman           	0:off	1:off	2:on	3:on	4:on	5:on	6:off
> rgmanager      	0:off	1:off	2:on	3:on	4:on	5:on	6:off
> scsi_reserve   	0:off	1:off	2:on	3:on	4:on	5:on	6:off
> 
> Removing the same node again sets the services to disabled, except scsi_reserve:
> [root@virt-159 ~]# chkconfig --list | egrep "rgmanager|cman|clvmd|scsi_reserve"
> clvmd          	0:off	1:off	2:off	3:off	4:off	5:off	6:off
> cman           	0:off	1:off	2:off	3:off	4:off	5:off	6:off
> rgmanager      	0:off	1:off	2:off	3:off	4:off	5:off	6:off
> scsi_reserve   	0:off	1:off	2:on	3:on	4:on	5:on	6:off

Not sure if it is by design, that we ignore fact we enabled scsi_reserve and
not disabling it again when removing the respective node.

+ there may be more such instances (to be investigated)
Comment 1 Ryan McCabe 2013-08-23 22:22:44 EDT
It's by design. SCSI reservations may be needed for non-cluster related storage. We can't easily and safely decide whether or not this is the case from conga, though.

Note You need to log in before you can comment on or make changes to this bug.