Bug 1000550 - yum update bug
yum update bug
Status: CLOSED DUPLICATE of bug 989145
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 11:59 EDT by George R. Goffe
Modified: 2013-08-26 09:05 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 09:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
flat file containing output of "yum update" and "yum check (8.09 KB, text/plain)
2013-08-23 11:59 EDT, George R. Goffe
no flags Details

  None (edit)
Description George R. Goffe 2013-08-23 11:59:21 EDT
Created attachment 789650 [details]
flat file containing output of "yum update" and "yum check

Description of problem:

Running yum update on newly installed Fedora 19 x86_64 fails

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1.Type in "yum update"
2.Observe error messages (enclosed)
3.

Actual results:

yum failure

Expected results:

yum success

Additional info:

See attached console log for "yum update" and "yum check"
Comment 1 Jan Zeleny 2013-08-26 04:04:52 EDT
There are several problems I can see, none of which point to a bug in yum. First of all you have some multilib problems (caused either by faulty installation or by packages themselves) - just uninstall one architecture of the libusb and libusb-devel and you should be fine.

The other problem probably lies in the package kde-settings itself. Reassigning the bug for further evaluation.
Comment 2 George R. Goffe 2013-08-26 04:13:46 EDT
Jan,

Thank you for your information.

I'll check this out in the morning. One of the rpm's (I think it was one of the settings rpms) I tried to remove got a "scriptlet" error of some kind.

I don't see how one can get a faulty installation. Do you mean installation via DVD or a "yum install" problem? This system is x86_64 but does have some ix86 pkgs for the software that doesn't know about x86_64 yet.

Thanks again,

George...
Comment 3 Jan Zeleny 2013-08-26 06:21:41 EDT
(In reply to George R. Goffe from comment #2)
> Jan,
> 
> Thank you for your information.
> 
> I'll check this out in the morning. One of the rpm's (I think it was one of
> the settings rpms) I tried to remove got a "scriptlet" error of some kind.

Yeah, that's the reason why I reassigned this bug to kde-settings component, the uninstallation failed in that package.

> I don't see how one can get a faulty installation. Do you mean installation
> via DVD or a "yum install" problem? This system is x86_64 but does have some
> ix86 pkgs for the software that doesn't know about x86_64 yet.

That's probably the root cause of the multilib problem that yum reports. I am no expert in multilib but I don't think there is anything yum can do about it, the solution is IMO to uninstall one arch of the libusb library - either the i686 or x86_64.
Comment 4 Rex Dieter 2013-08-26 09:05:33 EDT
See bug #989145 for the kde-settings scriptlet issue.

The other problem(s) can likely be resolved with 'yum distro-sync'

*** This bug has been marked as a duplicate of bug 989145 ***

Note You need to log in before you can comment on or make changes to this bug.