This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1000600 - Don't ask to replace content on import if canvas is empty.
Don't ask to replace content on import if canvas is empty.
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 15:40 EDT by Marek Baluch
Modified: 2013-08-26 11:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 11:00:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (170.94 KB, image/png)
2013-08-23 15:40 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-08-23 15:40:32 EDT
Created attachment 789704 [details]
screenshot

If I create a new process definition and try to import content then designer asks conformation to replace the existing model which is empty at that time. See attached screenshot.
Comment 1 Tihomir Surdilovic 2013-08-26 10:29:10 EDT
The reason that was done this way is that users could have modified process properties. So even if there are no nodes on the canvas, the user could have defined process variables, etc which would get overwritten by the import.
Comment 2 Marek Baluch 2013-08-26 11:00:00 EDT
OK - that makes sense. Closing as NOT_A_BUG.

Note You need to log in before you can comment on or make changes to this bug.