Bug 1000609 - A problem with ABRT
A problem with ABRT
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Marko
Fedora Extras Quality Assurance
abrt_hash:0114e5f72c7130b4aa4157b4c73...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 16:13 EDT by Paul DeStefano
Modified: 2016-01-31 21:23 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 06:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (47.12 KB, text/plain)
2013-09-03 16:46 EDT, Paul DeStefano
no flags Details
core_backtrace (1.11 KB, text/plain)
2013-09-03 16:47 EDT, Paul DeStefano
no flags Details

  None (edit)
Description Paul DeStefano 2013-08-23 16:13:38 EDT
Description of problem:
I'm trying to sumbit a crash report, but ABRT will not let me.
There are at least three problems to report.

1) after sumbitting crash data to the remote backtrace server, 
ABRT says "reporting disabled because bactrace is unusable" when, in fact, 
the backtrace analysis seems to have worked just fine.

...
Uploading 93%
Uploading 98%
Upload successful
Retrace job started
Analyzing crash data
Preparing environment for backtrace generation
......................................
Generating backtrace
....................
Cleaning environment after backtrace generation
Retrace job finished successfully
Looking for similar problems in bugzilla


2) remote backtrace generation log shows this error at the top, before uploading

--- Running report_uReport ---
Server responded with an error: 'Validation failed: error validating 'core_backtrace': missing mandatory element 'offset''

3) The above error is not either not notice or ignored by ABRT, so it's not clear if this is the
reason why the backtrace cannot be used or not.  ABRT should either indicate that this error
is being igored or should stop when the error is generated.

Version-Release number of selected component:
gnome-abrt-0.3.0

Additional info:
reporter:       libreport-2.1.6
kernel:         3.10.6-200.fc19.x86_64
type:           libreport
Comment 1 Richard Marko 2013-09-02 10:40:47 EDT
Thanks for the report. If possible, please provide 'core_backtrace' and 'backtrace' files of this crash (available in /var/tmp/abrt/<crash_dir>/) so we can investigate why the generated backtrace is corrupted.

Regarding the confusing error messages: reporting the uReport to our server is the first step of the reporting and it's not critical for the rest of the process -> if it fails, you can still proceed with reporting which means that 
 - retracing is done
 - bug is reported to bugzilla (if possible).

That means we don't really know if it would be possible to report to bugzilla until we are done with retracing which might produce unusable backtrace.
Comment 2 Paul DeStefano 2013-09-03 16:46:33 EDT
Created attachment 793354 [details]
Backtrace

Thank you for your help.  It was only a week ago, but I can't quite remember which backtrace it was that was unusable.  I think it is this one.  I'll also attach the core_backtrace file, too.
Comment 3 Paul DeStefano 2013-09-03 16:47:19 EDT
Created attachment 793362 [details]
core_backtrace

Here is the core_backtrace, too.
Comment 4 Paul DeStefano 2013-09-03 16:52:56 EDT
BTW, since I wasn't sure, I tried to submit this backtrace the normal way and it didn't give the eariler error

Server responded with an error: 'Validation failed: error validating 'core_backtrace': missing mandatory element 'offset''

This time, the server didn't give an error.  But, the result was and unusable backtrace, just like the main problem I reported in this bug.  So, I think this is a backtrace from the same program that crashed originally.  It's xfce-sensors-plugin.
Comment 5 Richard Marko 2013-09-04 05:30:01 EDT
Thanks for the files.

The problem is that you are using proprietary nvidia drivers. This leads to stacktrace with multiple unknown frames which is in most cases insufficient for debugging.

The only thing we can do here is to give user an explanation why the backtrace is unusable.
Comment 6 Paul DeStefano 2013-09-04 22:35:03 EDT
Ah!  Okay, thank you very much for the explanation.

So, is this going to be a problem with *all* backtraces or just this one from xfce-sensors-plugin.  I mean, if this is a sensors thing, that's find; I understand.  But, if the tainted kernel invalidates backtraces for any program at all, that's a big deal.
Comment 7 Richard Marko 2013-09-09 10:15:07 EDT
(In reply to Paul DeStefano from comment #6)
> So, is this going to be a problem with *all* backtraces or just this one
> from xfce-sensors-plugin.  I mean, if this is a sensors thing, that's find;
> I understand.  But, if the tainted kernel invalidates backtraces for any
> program at all, that's a big deal.

It won't be a problem with all backtraces as it depends on the application and where it actually crashes (e.g. if it's using graphical stack or not).

Tainted kernel is a different issue - it only affects reporting of kernel oopses, not userspace crashes.
Comment 8 Paul DeStefano 2013-09-10 19:17:25 EDT
Okay, thanks for everything.
Comment 9 Fedora End Of Life 2015-01-09 17:16:06 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2015-02-18 06:24:42 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.