Bug 1000610 - Cannot complete process task if it requires data.
Cannot complete process task if it requires data.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.0.0
Assigned To: Mauricio Salatino
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 16:15 EDT by Marek Baluch
Modified: 2014-08-06 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
BPMS 6.0.0.ER1
Last Closed: 2014-08-06 16:13:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
frozen_task_view (109.93 KB, image/png)
2013-08-23 16:15 EDT, Marek Baluch
no flags Details
log (320.93 KB, text/x-log)
2013-08-23 16:16 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-08-23 16:15:07 EDT
Created attachment 789725 [details]
frozen_task_view

Description of problem:
When a user tries to complete the self-evaluation task in the Evaluation process then the task window will freeze immediately after I switch to the 'Work' tab. 

See attached screenshot. Looks like freemaker is having a hard time to render/create the form.

How to reproduce:
1) run the evaluation process
2) attempt to complete the first task
Comment 1 Marek Baluch 2013-08-23 16:16:04 EDT
Created attachment 789726 [details]
log
Comment 2 Mauricio Salatino 2013-08-26 08:39:29 EDT
The self evaluation provides custom forms generated with the form modeller, why is that looking for ftl files?
Comment 3 Mauricio Salatino 2013-08-27 06:04:13 EDT
This is working ok in master. Can you please specify which Employee ID did you use in the Process Form (when you started the instance)? notice that it must be an existing user, because the first task of the process will be assigned to it.
Comment 4 Marek Baluch 2013-08-27 07:11:15 EDT
The thing I did is the following:

1) I started the process as mary. 
2) rules where used to assign mary to the task and to put the task into RESERVED state.
3) then I used the console to complete the task.

I tried a 6.0.0-SNAPSHOT from yesterday and the original issue is gone. I think we can close this BZ.
Comment 5 Marek Baluch 2013-09-19 10:14:58 EDT
Verified on ER3.
Comment 9 Marek Baluch 2014-02-26 08:33:39 EST
BigApp tests cover this use case.

Note You need to log in before you can comment on or make changes to this bug.