Bug 1000620 - pkg-config has wrong configuration
pkg-config has wrong configuration
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qpid-proton (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1002290
  Show dependency treegraph
 
Reported: 2013-08-23 17:02 EDT by Andrew Stitcher
Modified: 2015-06-21 20:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: qpid-proton-0.5-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1002290 (view as bug list)
Environment:
Last Closed: 2013-09-06 21:23:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA PROTON-412 None None None Never

  None (edit)
Description Andrew Stitcher 2013-08-23 17:02:44 EDT
Description of problem:

From /usr/lib64/pkgconfig/libqpid-proton.pc -

prefix=/usr
exec_prefix=/usr
libdir=/usr/usr/lib64
includedir=/usr/usr/include

Note that prefix and exec_prefix are correct but libdir and includedir don't make any sense.

This might be an issue with the upstream package or the rpm packaging process. It looks like there is an extraneous /usr/ in the way that libdir and indlucedir are constructed.

Version-Release number of selected component (if applicable):
0.4-3

How reproducible:
100%

Steps to Reproduce:
1. yum install qpid-proton-c-devel
2.
3.

Actual results:
As description

Expected results:
File extract above should be:

prefix=/usr
exec_prefix=/usr
libdir=/usr/lib64
includedir=/usr/include

Additional info:
Comment 1 Darryl L. Pierce 2013-08-26 08:54:30 EDT
Looking in the CMakeLists.txt file located in proton-c, the issue appears to be with:

  get_filename_component (LIBDIR ${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR} ABSOLUTE)
  get_filename_component (INCLUDEDIR ${CMAKE_INSTALL_PREFIX}/${INCLUDE_INSTALL_DIR} ABSOLUTE)

Specifically, CMAKE_INSTALL_PREFIX, LIB_INSTALL_DIR and INCLUDE_INSTALL_DIR are all absolute root paths. So mixing them together as is being done above causes a problem.

So perhaps a better approach would be to only use INCLUDE_INSTALL_DIR and LIB_INSTALL_DIR in the above.

And to allow for the developer to use CMAKE_INSTALL_PREFIX only if provided and, if it is, use it to define LIB_INSTALL_DIR and/or INCLUDE_INSTALL_DIR only if the respective value wasn't provided on the commandline as well.
Comment 2 Fedora Update System 2013-08-28 13:37:59 EDT
qpid-proton-0.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qpid-proton-0.5-1.fc19
Comment 3 Fedora Update System 2013-08-28 14:44:53 EDT
qpid-proton-0.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-proton-0.5-1.fc18
Comment 4 Fedora Update System 2013-08-29 18:22:20 EDT
Package qpid-proton-0.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qpid-proton-0.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15506/qpid-proton-0.5-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-06 21:23:28 EDT
qpid-proton-0.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-09-06 21:27:07 EDT
qpid-proton-0.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.