Bug 1000643 - no hardening build
no hardening build
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 19:37 EDT by Harald Reindl
Modified: 2014-03-21 05:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: gpsd-3.9-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 08:42:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-08-23 19:37:20 EDT
this clearly violates the guidelines

https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#PIE

"If your package meets any of the following criteria you MUST enable the PIE compiler flags: Your package is long running" is not a opt-in
_________________________________

gpsd-3.9-1.fc18.x86_64

hardening-check /usr/sbin/gpsd
/usr/sbin/gpsd:
 Position Independent Executable: no, normal executable!
 Stack protected: yes
 Fortify Source functions: yes (some protected functions found)
 Read-only relocations: yes
 Immediate binding: no, not found!
Comment 1 Fedora Update System 2014-02-14 08:54:30 EST
gpsd-3.9-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gpsd-3.9-3.fc20
Comment 2 Fedora Update System 2014-03-21 05:36:32 EDT
gpsd-3.9-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.