Bug 1000673 - Konqueror does not work with Flash without /usr/lib64/mozilla/plugins/libflashplayer.so symlink
Konqueror does not work with Flash without /usr/lib64/mozilla/plugins/libflas...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 02:23 EDT by Karel Volný
Modified: 2014-05-17 02:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: kde-baseapps-4.12.5-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-14 19:55:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-08-24 02:23:09 EDT
Description of problem:
After a fresh install, I've added Adobe repo and installed the flash-plugin as described here: http://fedoraproject.org/wiki/Flash#x86_64_.2864-bit.29

However, Konqueror did not recognise the newly installed plugin.

So I went to the settings and I have found that it does not search the path used by the Adobe package, so I've added /usr/lib64/flash-plugin/ manually.

After rescanning, it showed the plugin. But it still did not work, despite closing and reopening Konqueror to be sure the settings apply etc.

I gave up and went to install Seamonkey. What was my surprise to find that after Seamonkey installation, Flash suddenly started to work also in Konqueror (in an already running window).

Seems that the reason is that Seamonkey creates a symlink:
# ls -l /usr/lib64/mozilla/plugins/
celkem 4
lrwxrwxrwx. 1 root root 41 24. srp 08.09 libflashplayer.so -> /usr/lib64/flash-plugin/libflashplayer.so


Version-Release number of selected component (if applicable):
kde-baseapps-4.10.5-1.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. follow http://fedoraproject.org/wiki/Flash#x86_64_.2864-bit.29
2. go to http://www.adobe.com/software/flash/about/


Actual results:
you see missing plugin symbol


Expected results:
there is a "Version information" box shown

Additional info:
Comment 1 Karel Volný 2013-08-24 02:59:55 EDT
(In reply to Karel Volný from comment #0)
> Steps to Reproduce:
> 1. follow http://fedoraproject.org/wiki/Flash#x86_64_.2864-bit.29
> 2. go to http://www.adobe.com/software/flash/about/

insert

0. install Fedora 19 with KDE

(just to highlight that it was stock desktop install, not a minimal one or something like that)
Comment 2 Kevin Kofler 2013-08-25 19:16:17 EDT
So the proprietary Flash plugin is packaged incorrectly by Adobe (it doesn't work at all in the path it gets installed to, even if you add it to Konqueror's search path), why would that be Konqueror's fault?

Konqueror is not going to make any symlinks in /usr/lib64/mozilla/plugins/, that path belongs to Mozilla.
Comment 3 Karel Volný 2013-12-05 06:55:56 EST
(In reply to Kevin Kofler from comment #2)
> So the proprietary Flash plugin is packaged incorrectly by Adobe (it doesn't
> work at all in the path it gets installed to, even if you add it to
> Konqueror's search path), why would that be Konqueror's fault?

well, do you have any argument why it _is not_ Konqueror's fault?

how do you deduce that it is Flash's fault and not a problem in the way Konqueror tries to use it?

> Konqueror is not going to make any symlinks in /usr/lib64/mozilla/plugins/,
> that path belongs to Mozilla.

I haven't said it should, but it is a clue - knowing what makes it work could be a first step to find out how to fix/workaround ... and even if it really is Adobe's problem then I think Konqueror should be[*] able to workaround it if Seamonkey is able

btw, I would see that as a _correct_ packaging by Adobe, if they do not touch something owned by someone else ...

[*] blaming Adobe won't help ordinary users, it is unlikely to get the blob fixed, unfortunately many useful sites don't work at all without Flash, and Fedora is not FSF approved totally libre distro to lead religious war against non-opensource software
Comment 4 Rex Dieter 2013-12-05 07:49:05 EST
$ rpm -q flash-plugin
flash-plugin-11.2.202.327-release.x86_64

ls /usr/lib64/mozilla/plugins/libflashplayer.so 
/usr/lib64/mozilla/plugins/libflashplayer.so

worksforme.
Comment 5 Rex Dieter 2013-12-05 07:57:14 EST
In all seriousness, if flash-plugin install fails to make that symlink, it won't work with mozilla/firefox either.
Comment 6 Chris Cheney 2014-05-02 22:25:32 EDT
The problem here is that Adobe detects which browsers are installed by looking for the plugin directories, and since /usr/lib64/mozilla/plugins does not exist when only konqueror is installed it does not create a symlink for flash.

It does seem odd that Konqueror can't use the flash plugin it can see in the original directory though.

A workaround for this issue is to run the following:

mkdir /usr/lib64/mozilla/plugins
/usr/lib64/flash-plugin/setup 64 upgrade
Comment 7 Rex Dieter 2014-05-03 19:52:16 EDT
Ah thanks for that detail!

I think we can fix this, by adding a dependency on mozilla-filesystem pkg (which owns /usr/lib64/mozilla-plugins)
Comment 8 Fedora Update System 2014-05-04 00:06:33 EDT
kde-baseapps-4.11.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-baseapps-4.11.5-2.fc19
Comment 9 Fedora Update System 2014-05-05 23:34:51 EDT
Package kde-baseapps-4.11.5-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-baseapps-4.11.5-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6010/kde-baseapps-4.11.5-2.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-05-06 11:53:15 EDT
kde-baseapps-4.12.5-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kde-baseapps-4.12.5-2.fc20
Comment 11 Fedora Update System 2014-05-14 19:55:10 EDT
kde-baseapps-4.11.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2014-05-17 02:31:20 EDT
kde-baseapps-4.12.5-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.