Bug 1000674 - orphan symlink /usr/lib64/mozilla/plugins/libflashplayer.so not under rpm control
orphan symlink /usr/lib64/mozilla/plugins/libflashplayer.so not under rpm con...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 02:34 EDT by Karel Volný
Modified: 2013-08-24 13:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-24 13:23:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-08-24 02:34:21 EDT
Description of problem:
After installing Adobe Flash and then Seamonkey, a symlink is created for the libflasplayer.so library.

After uninstalling Seamonkey (and the dependencies), this link and the parent directories are left behind.

Version-Release number of selected component (if applicable):
seamonkey-2.20-1.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. follow http://fedoraproject.org/wiki/Flash#x86_64_.2864-bit.29
2. yum install seamonkey
3. rpm -qf /usr/lib64/mozilla/plugins/libflashplayer.so
4. yum remove mozilla-filesystem
5. ls -l /usr/lib64/mozilla/plugins/

Actual results:
3. file /usr/lib64/mozilla/plugins/libflashplayer.so is not owned by any package
5. lrwxrwxrwx. 1 root root 41 24. srp 08.09 libflashplayer.so -> /usr/lib64/flash-plugin/libflashplayer.so

Expected results:
3. seamonkey-2.20-1.fc19.x86_64
5. ls: cannot access /usr/lib64/mozilla/plugins: No such file or directory

Additional info:
I really do not know how the link gets created - I see nothing relevant in package scripts ...
Comment 1 Dmitry Butskoy 2013-08-24 13:23:48 EDT
> After uninstalling Seamonkey (and the dependencies), this link and the parent directories are left behind.

Because the symlink might be useful for other browser software, using the same "common" /usr/lib64/mozilla/plugins directory, ie. firefox, opera.

The symlink is created by flash-plugin package, either by pre/post install scriptlet, or by triggers. In the case you describe it is by "triggerin" scriptlet:

$ rpm -q --triggers flash-plugin
triggerin scriptlet (using /bin/sh) -- firefox, mozilla, opera, seamonkey
/usr/lib64/flash-plugin/setup upgrade

But there is no "triggerun" scriptlet, hence nothing is done by flash-plugin when some of these packages are removed/updated.

Moreover, authors of the flash-plugin (Adobe?) do not provide a Fedora-specific package and know nothing about the fact that /usr/lib64/mozilla directory is owned by "mozilla-filesystem" special package (hence it looks like they should use "mozilla-filesystem" instead of the browser list in the trigger scriptlet etc.)

But anyway, flash-plugin is a proprietary software and not a part of Fedora. Lets leave things as is...

Note You need to log in before you can comment on or make changes to this bug.