Bug 1000685 - artifacts on windows corners
artifacts on windows corners
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 05:51 EDT by Tomasz Torcz
Modified: 2015-01-22 02:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-22 02:50:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
control-center-corners.png (25.64 KB, image/png)
2013-08-24 05:51 EDT, Tomasz Torcz
no flags Details

  None (edit)
Description Tomasz Torcz 2013-08-24 05:51:28 EDT
Created attachment 789813 [details]
control-center-corners.png

Description of problem:
Control-center windows are rounded but with square artifacts. See the attachment.
I cannot reproduce it with different programs, like gcalctool. Control center seem to be the only one affected.

Version-Release number of selected component (if applicable):
control-center-3.9.90.1-1.fc20.x86_64
gtk3-3.9.12-1.fc20.x86_64
mesa-dri-drivers-9.2-0.15.20130723.fc20.x86_64

OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset
Comment 1 Elad Alfassa 2013-08-24 08:25:57 EDT
That is a known problem, which should be handled upstream. It affects every app that uses the new GTK HeaderBar. If you start it with GTK_CSD=1 environment variable, you won't see the square "artifacts".
Comment 2 Tomasz Torcz 2015-01-22 02:50:17 EST
Got fixed somewhere along the way.

Note You need to log in before you can comment on or make changes to this bug.