Bug 1000712 - wrong %post
wrong %post
Status: CLOSED DUPLICATE of bug 995158
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 09:50 EDT by Michael Scherer
Modified: 2013-08-26 04:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 04:08:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2013-08-24 09:50:16 EDT
$ rpm -q --scripts acpid 
preinstall scriptlet (using /bin/sh):
if [ "$1" = "2" ]; then
	conflist=`ls /etc/acpi/events/*.conf 2> /dev/null`
	RETCODE=$?
	if [ $RETCODE -eq 0 ]; then
		for i in $conflist; do
			rmdot=`echo $i | sed 's/.conf/conf/'`
	 		mv $i $rmdot
		done
	fi
fi
postinstall scriptlet (using /bin/sh):
%systemd_post acpid.service
preuninstall scriptlet (using /bin/sh):
%systemd_preun acpid.service
postuninstall scriptlet (using /bin/sh):
%systemd_postun_with_restart acpid.service

It seems the macros were not expanded correctly.

And this package is the one in update :
$ rpm -q  acpid          
acpid-2.0.19-5.fc19.x86_64
Comment 1 Jaroslav Škarvada 2013-08-26 04:08:56 EDT
It should be fixed in acpid-2.0.19-6.fc19. You will probably need to get rid of the acpid-2.0.19-5.fc19 by using rpm with the --noscripts parameter. Sorry for the inconvenience something in the build system changed.

*** This bug has been marked as a duplicate of bug 995158 ***

Note You need to log in before you can comment on or make changes to this bug.