Bug 1000737 - after 'yum install bugzilla' checksetup.pl fails. dependancies missing and incorrect.
after 'yum install bugzilla' checksetup.pl fails. dependancies missing and in...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Email-Send (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 15:48 EDT by Paul Houghton
Modified: 2013-09-30 21:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: perl-Email-Send-2.199-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 22:28:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Houghton 2013-08-24 15:48:25 EDT
Description of problem:

Performed 'yum install bugzilla' on a 2 month old fresh fedora 19 install with all yum package updates. The checksetup.pl failed because of missing perl module dependancies.

How reproducible:

every time on my system, but don't have any additional systems to test on.

Steps to Reproduce:
1. yum install bugzilla # (repository was: #http://download.fedoraproject.org/pub/fedora/linux/updates/ )

2. cd /usr/share/bugzilla

3. ./checksetup.pl

Actual results:

a list of missing packages and instructions to run the following commands:
yum install "perl(Chart::Lines)"
yum install "perl(Template::Plugin::GD::Image)"
yum install "perl(GD::Text)"
yum install "perl(GD::Graph)"
yum install "perl(XML::Twig)"
yum install "perl(PatchReader)"
yum install "perl(Authen::Radius)"
yum install "perl(JSON::RPC)"
yum install "perl(JSON::XS)"
yum install "perl(Test::Taint)"
yum install "perl(HTML::Scrubber)"
yum install "perl(Encode::Detect)"
yum install "perl(Email::MIME::Attachment::Stripper)"
yum install "perl(Email::Reply)"
yum install "perl(Daemon::Generic)"

Even after running the suggested commands checkup.pl continued to complain about  the Email::Reply module.

The version installed by yum install was broken and replaced by a newer version.

Note: there is also bug in the Email::Reply CPAN release (1.202). It is not correctly resolving the dependency on the latest Email::Abstract which is also out of date in the yum repository (has 3.002 need 3.005).

Expected results:

checksetup.pl to at least have gotten to the database section. 

Additional info:

My solution:

perl -MCPAN -e shell
cpan> install Email::Abstract
cpan> install Email::reply
cpan> exit
cd /usr/share/bugzilla
./checksetup.pl

Now is complaining about mysql and localconfig, which is expected.
Comment 1 Emmanuel Seyman 2013-08-24 16:09:03 EDT
(In reply to Paul Houghton from comment #0)
>
> a list of missing packages and instructions to run the following commands:

[snip list of yum commands]

These all look like optional dependencies and checksetup.pl should keep going even if they are missing. Is there anyone of these modules that isn't ?

> Even after running the suggested commands checkup.pl continued to complain
> about  the Email::Reply module.

Are you sure about this ? Email::Reply is definitely optional.

Emmanuel
Comment 2 Timothée Ravier 2013-09-04 09:19:27 EDT
I had a very similar issue where bugzilla checksetup.pl would complain about missing the Email::Send module even though it was already installed.

I had a look at another bugzilla install and found out that the Module::Pluggable module seems required and it indeed fixed my problem.

I think this module should be added as a dependency.
Comment 3 Emmanuel Seyman 2013-09-04 12:06:22 EDT
(In reply to Timothée Ravier from comment #2)
> I had a very similar issue where bugzilla checksetup.pl would complain about
> missing the Email::Send module even though it was already installed.

That sounds much more plausible. Paul, is this what you were seeing ?

> I had a look at another bugzilla install and found out that the
> Module::Pluggable module seems required and it indeed fixed my problem.

Removing perl-Module-Pluggable has the effect that checksetup can no longer detect Email-Send. Running the command "perl -MEmail::Send -e '1'" gives the following error :

Can't locate Module/Pluggable.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/perl5/vendor_perl/Email/Send.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Email/Send.pm line 10.
Compilation failed in require.
BEGIN failed--compilation aborted.

So Module::Pluggable is required by Email::Send but the package containing the latter doesn't depend on the former. And bugzilla then fails because Email::Send doesn't work.

Looking at Email::Send's source code, I suspect rpm doesn't understand the 'use Module::Pluggable' line (note the lack of semi-colon at the end) and doesn't include the dependency automatically.

> I think this module should be added as a dependency.

Definatly but it should be added in the perl-Email-Send package where it will get pick up by all Email::Send users and not just bugzilla.

Spot, this one's yours.
Comment 4 Fedora Update System 2013-09-04 12:37:28 EDT
perl-Email-Send-2.199-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-Email-Send-2.199-1.fc20
Comment 5 Fedora Update System 2013-09-04 12:37:45 EDT
perl-Email-Send-2.199-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Email-Send-2.199-1.fc18
Comment 6 Fedora Update System 2013-09-04 12:37:55 EDT
perl-Email-Send-2.199-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-Email-Send-2.199-1.fc19
Comment 7 Fedora Update System 2013-09-04 21:33:18 EDT
Package perl-Email-Send-2.199-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Email-Send-2.199-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15795/perl-Email-Send-2.199-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-09-13 22:28:20 EDT
perl-Email-Send-2.199-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-09-13 22:35:32 EDT
perl-Email-Send-2.199-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-09-30 21:54:43 EDT
perl-Email-Send-2.199-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.