Bug 1000738 - remote-viewer application error exception 0x40000015
remote-viewer application error exception 0x40000015
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: virt-viewer (Show other bugs)
unspecified
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: Daniel Berrange
:
: 1062749 (view as bug list)
Depends On:
Blocks: 1063709
  Show dependency treegraph
 
Reported: 2013-08-24 15:58 EDT by jblawn
Modified: 2016-01-06 06:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1063709 (view as bug list)
Environment:
Last Closed: 2016-01-06 06:07:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
event log entry (625 bytes, text/plain)
2013-08-24 15:58 EDT, jblawn
no flags Details
debug output (1.26 KB, text/plain)
2013-08-25 00:59 EDT, jblawn
no flags Details
memory usage (52.18 KB, image/jpeg)
2013-08-25 01:09 EDT, jblawn
no flags Details

  None (edit)
Description jblawn 2013-08-24 15:58:10 EDT
Created attachment 789901 [details]
event log entry

Description of problem:
remote-viewer randomly crashes when using Windows x64 package

Version-Release number of selected component (if applicable):
0.5.7 x64 build

How reproducible:
Nothing specific.  Used long enough remote-viewer crashes.

Steps to Reproduce:
1. None

Actual results:


Expected results:


Additional info:
Windows host details
Windows 7 Enterprise SP1 6.1.7601 x64

Linux host details
Fedora 19 x86_64, 3.10.9
libvirt 1.0.5.5-1
qemu-kvm 1.4.2-7
virt-manager 0.10.0-1

Using QXL/spice, latest spice guest tools installed in Windows guest (0.59)
Local virt-manager session does not crash
remote-viewer session running on Linux to same VM does not crash
Comment 1 jblawn 2013-08-25 00:59:29 EDT
Created attachment 790002 [details]
debug output
Comment 2 jblawn 2013-08-25 01:09:47 EDT
Created attachment 790003 [details]
memory usage
Comment 3 jblawn 2013-08-25 01:12:20 EDT
After further investigation, there appears appears to be a memory leak which is why the crash is random.  remote-viewer process will get to approx. 500MB and then crash.
Comment 4 Benjamin Reiter 2013-12-12 10:00:05 EST
I can confirm this bug. Remote-Viewer.exe crashes after a while due to high memory consumption. Easily reproducible by opening the theme selection on a Windows 7 guest and cycling between the themes "Windows 7" and "Windows Classic".

Is there a workaround or fix available?

Guest-OS is Windows 7 x64
Remote-Viewer Client x64 on OS Windows 7 x64
Comment 5 Benjamin Reiter 2014-02-03 13:30:32 EST
This is still happening with version 0.6.0. Both x32 and x64.
Comment 6 Markus Stockhausen 2014-02-09 12:17:52 EST
VNC sessions seem to be affected by this bug too.  The easiest way I could reproduce the bug was opening a window in the windows VM. Afterwards just click on the taskbar icon to open/close the window cyclically. It takes only a minute  to raise the crash.

Most important: In my environment the bug shows up only when using 16bpp depth on the client. So at least one part of the problem should be this: 

https://bugzilla.gnome.org/show_bug.cgi?id=671538
Comment 7 Christophe Fergeau 2014-02-11 04:23:24 EST
Guess we should pull this fix in the mingw-gtk2 package even if it does not make it upstream...
Comment 8 Markus Stockhausen 2014-02-11 05:07:27 EST
I support this idea too. The bugfix exists since 11 months and did not find its way into gtk2. Several people reported that the fix works. For running virt-viewer in 16bbp this bugfix is nearly essential.
Comment 9 Markus Stockhausen 2014-02-11 11:54:42 EST
*** Bug 1062749 has been marked as a duplicate of this bug. ***
Comment 10 Pavel Grunt 2016-01-06 06:07:03 EST
The fix is in, and in the latest release gtk3 is used

Note You need to log in before you can comment on or make changes to this bug.