Bug 1000750 - Missing requires for python-kombu
Missing requires for python-kombu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-kombu (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
: Reopened
Depends On: 1000812
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 17:28 EDT by Michael Scherer
Modified: 2014-06-10 03:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-kombu-2.5.14-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 21:03:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dirty hack to get the package working (6.40 KB, text/x-rpm-spec)
2013-09-26 12:55 EDT, Dhiru Kholia
no flags Details
dirty hack to get the package working (231 bytes, patch)
2013-09-26 12:55 EDT, Dhiru Kholia
no flags Details | Diff

  None (edit)
Description Michael Scherer 2013-08-24 17:28:07 EDT
$ rpm -qf /usr/lib/python2.7/site-packages/kombu-2.5.8-py2.7.egg-info/requires.txt
python-kombu-2.5.8-1.fc19.noarch

$ cat /usr/lib/python2.7/site-packages/kombu-2.5.8-py2.7.egg-info/requires.txt 
anyjson>=0.3.3
amqp>=1.0.10,<1.1.0

$ rpm -q --requires python-kombu
python(abi) = 2.7
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


So there is :
- 1 misisng requires on python-anyjson
- 1 missing package for python amqp 

The missing package is on https://pypi.python.org/pypi/amqp/
Comment 1 Dhiru Kholia 2013-09-26 12:44:36 EDT
✗ rpm -qa | grep celery    
python-celery-3.0.19-2.fc20.noarch

✗ head /usr/bin/celery
#!/usr/bin/python3
...

1. Why does this file say "python3" instead of saying "python" ?

  This is a question for the maintainer of python-celery. I will file a separate bug for this.

2. After fixing the she-bang manually, I get,
✗ celery worker --autoscale=10,0 -A tasks
Traceback (most recent call last):
  File "/usr/bin/celery", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3011, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: amqp>=1.0.13,<1.1.0

...

This "pkg_resources.DistributionNotFound: amqp>=1.0.13,<1.1.0" problem is being caused by bad python-kombu packaging.

So, can we please get this fixed ASAP?
Comment 2 Dhiru Kholia 2013-09-26 12:55:22 EDT
Created attachment 803480 [details]
dirty hack to get the package working
Comment 3 Dhiru Kholia 2013-09-26 12:55:55 EDT
Created attachment 803481 [details]
dirty hack to get the package working
Comment 4 Matthias Runge 2013-09-27 03:12:01 EDT
Ugh, sorry. I fixed this for f19, but forgot to carry the patch up to master and f20. Update is following
Comment 5 Fedora Update System 2013-09-27 03:28:06 EDT
python-celery-3.0.19-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-celery-3.0.19-4.fc20
Comment 6 Fedora Update System 2013-09-27 20:23:40 EDT
Package python-celery-3.0.19-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-celery-3.0.19-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17860/python-celery-3.0.19-4.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-10 10:41:47 EDT
python-celery-3.0.19-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Alan Pevec 2013-12-10 06:46:33 EST
Not sure what happened here, comment 1 seems out of place and FiV python-celery-3.0.19-4.fc20 for a _python-kombu_ bug doesn't make sense.

python-kombu in F19 is not fixed, it's still python-kombu-2.5.8-1.fc19 as reported in description.
Comment 9 Fedora Update System 2013-12-10 07:17:07 EST
python-kombu-2.5.14-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-kombu-2.5.14-2.fc19
Comment 10 Fedora Update System 2013-12-10 20:59:17 EST
Package python-kombu-2.5.14-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-kombu-2.5.14-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23126/python-kombu-2.5.14-2.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-12-19 21:03:43 EST
python-kombu-2.5.14-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.