Bug 1000770 - ncat displays debug message during normal use
ncat displays debug message during normal use
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nmap (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Hlavinka
Martin Žember
:
Depends On:
Blocks: 947782 1134412
  Show dependency treegraph
 
Reported: 2013-08-24 22:15 EDT by Andreas M. Kirchwitz
Modified: 2015-07-13 00:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: nmap-5.51-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1134412 (view as bug list)
Environment:
Last Closed: 2014-06-10 08:24:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas M. Kirchwitz 2013-08-24 22:15:23 EDT
Description of problem:
When using ncat to connect through a HTTP proxy a debug message is displayed on screen. This breaks automated use of ncat.

$ /usr/bin/ncat --proxy-type http --proxy proxy.example.com:3128 www.example.com 443
NCAT DEBUG: Proxy returned status code 200.

Version-Release number of selected component (if applicable):
nmap-5.51-2.el6.i686

How reproducible:
Use ncat to connect through a HTTP proxy.

Steps to Reproduce:
1. see above
2.
3.

Actual results:
Debug message displayed.

Expected results:
No message displayed unless verbose output has been requested.

Additional info:
Fedora 19 had same bug (ticket 994376). If you ask why I'm using "ncat" instead of "nc", that's because "nc" is even more broken for use of HTTP proxy:

$ nc -X connect -x www.example.com:3128 www.example.com 443
nc: Proxy error: "HTTP/1.1 200 Connection established"
Comment 2 Michal Hlavinka 2013-09-10 08:07:50 EDT
reproducible
Comment 3 RHEL Product and Program Management 2013-10-13 19:14:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2014-06-10 08:24:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0683.html

Note You need to log in before you can comment on or make changes to this bug.