Bug 1000777 - assertion should not be enabled in RPM
assertion should not be enabled in RPM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: leveldb (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-25 03:01 EDT by Remi Collet
Modified: 2013-08-27 19:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: leveldb-1.12.0-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 19:28:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2013-08-25 03:01:03 EDT
Upstream Makefile suggest to use following build option

OPT ?= -O2 -DNDEBUG       # (A) Production use (optimized mode)
# OPT ?= -g2              # (B) Debug mode, w/ full line-level debugging symbols
# OPT ?= -O2 -g2 -DNDEBUG # (C) Profiling mode: opt, but w/debugging symbols


In Fedora RPM, of course standard build options are used, BUT without -DNDEBUG, so assert are enable.

Using this seem to solve this issue
  export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
  export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"

Note this should also fix bug #908800

I discover this working on the PHP connector for leveldb (php-pecl-leveldb) which raises a lot of assert during test suite.

Tested with leveldb 1.13.0 (released a few days ago), -DNDEBUG seems ok.
Comment 1 Peter Lemenkov 2013-08-25 03:21:31 EDT
Thanks for the report - I'll fix it shortly.

Regarding update to 1.13 - that's more complicated since I have to check compatibility with few other apps dependent on leveldb.
Comment 2 Fedora Update System 2013-08-26 00:33:17 EDT
leveldb-1.12.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/leveldb-1.12.0-5.fc19
Comment 3 Fedora Update System 2013-08-26 18:29:46 EDT
Package leveldb-1.12.0-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing leveldb-1.12.0-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15327/leveldb-1.12.0-5.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-27 19:28:54 EDT
leveldb-1.12.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.