This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1000800 - incorrect %post
incorrect %post
Status: CLOSED DUPLICATE of bug 996231
Product: Fedora
Classification: Fedora
Component: usbmuxd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-25 09:21 EDT by Michael Scherer
Modified: 2013-08-31 10:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 10:12:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix %postun typo (560 bytes, patch)
2013-08-25 09:21 EDT, Michael Scherer
no flags Details | Diff
add explicit BuildRequires on systemd for macros (707 bytes, patch)
2013-08-25 09:23 EDT, Michael Scherer
no flags Details | Diff

  None (edit)
Description Michael Scherer 2013-08-25 09:21:35 EDT
Created attachment 790069 [details]
fix %postun typo

On fedora 20 :
[fedora@vm1 ~]$ rpm -q --scripts usbmuxd

preinstall scriptlet (using /bin/sh):
getent group usbmuxd >/dev/null || groupadd -r usbmuxd -g 113
getent passwd usbmuxd >/dev/null || \
useradd -r -g usbmuxd -d / -s /sbin/nologin \
	-c "usbmuxd user" -u 113 usbmuxd
exit 0
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
%systemd_post usbmuxd.service
preuninstall scriptlet (using /bin/sh):
%systemd_preun usbmuxd.service

%postun/
sbin/ldconfig
%systemd_postun_with_restart usbmuxd.service

there is 1 typo in %postun

and there is unexpanded macro, due to missing systemd.

here is 2 patch to fix this.
Comment 1 Michael Scherer 2013-08-25 09:23:22 EDT
Created attachment 790070 [details]
add explicit BuildRequires on systemd for macros
Comment 2 Peter Robinson 2013-08-31 10:12:18 EDT

*** This bug has been marked as a duplicate of bug 996231 ***

Note You need to log in before you can comment on or make changes to this bug.