Bug 1000801 - Although when creating network with profile you check "Public" checkbox, the "Permission" for everyone is not created
Although when creating network with profile you check "Public" checkbox, the ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
high Severity unspecified
: ---
: 3.3.0
Assigned To: Lior Vernia
GenadiC
network
:
Depends On:
Blocks: 3.3snap1
  Show dependency treegraph
 
Reported: 2013-08-25 09:29 EDT by GenadiC
Modified: 2016-02-10 14:51 EST (History)
9 users (show)

See Also:
Fixed In Version: is19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (833.34 KB, text/x-log)
2013-08-25 09:29 EDT, GenadiC
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18826 None None None Never
oVirt gerrit 19773 None None None Never
oVirt gerrit 20087 None None None Never

  None (edit)
Description GenadiC 2013-08-25 09:29:18 EDT
Created attachment 790071 [details]
engine log

Description of problem:
When you create new network with specific VNIC profile and check the "Public" checkbox in there, the new permission for everyone should be created and it isn't

How reproducible:
Always

Steps to Reproduce:
1. Create network with VNIC profile in one step
2. Check the "Public" checkbox (checked by default)
3.

Actual results:
VNIC profile that is created is missing permission for everyone

Expected results:
VNIC profile should include permission for everyone

Additional info:
 When creating the new VNIC (without creating it as a part of Network creation) the VNIC profile has permission for everyone ( as expected)
Comment 1 Moti Asayag 2013-09-29 06:21:46 EDT
The commit which fixes this bug is already merged when solved:
Bug 1001105 - Permission for everyone are not reflected on specific user
Bug 1003787 - Creating VNIC profile with "Allow all user..." checkbox checked results in Null(Network) permissions under Users permissions

Moving to ON_QA so this scenario will be verified as well.
Comment 3 Moti Asayag 2013-10-01 04:16:43 EDT
Updating components to webadmin since problem resides on NetworkModel.performVnicProfileAction which ignores the "public" flag on Add/Edit network dilaogs.
Comment 4 GenadiC 2013-10-20 03:52:05 EDT
Verified in IS19
Comment 5 Itamar Heim 2014-01-21 17:30:13 EST
Closing - RHEV 3.3 Released
Comment 6 Itamar Heim 2014-01-21 17:30:13 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:33:15 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.