Bug 1000819 - pkgconfig file for libcmis-c-0.3-3f19 is broken
pkgconfig file for libcmis-c-0.3-3f19 is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libcmis (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-25 11:56 EDT by Benjamin Kahn
Modified: 2013-09-08 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: libcmis-0.3.1-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 19:26:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2013-08-25 11:56:16 EDT
Description of problem:
pkgconfig file for libcmis-c-0.3 is broken

Version-Release number of selected component (if applicable):
0.3.1-3.fc19

How reproducible:
Always

Steps to Reproduce:
1. install libcmis-devel
2. exec: pkg-config libcmis-c-0.3 --libs

Actual results:
You get this error:

Package libcmis was not found in the pkg-config search path.
Perhaps you should add the directory containing `libcmis.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libcmis', required by 'libcmis', not found

Expected results:
You should see:
-lcmis-c-0.3 -lcmis-0.3 -lcurl -lxml2

Additional info:
The problem is that the file: /usr/lib64/pkgconfig/libcmis-c-0.3.pc lists "libcmis" on the Requires: line.

However, the name of the library is "libcmis-0.3"
Comment 1 Fedora Update System 2013-08-30 14:46:37 EDT
libcmis-0.3.1-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libcmis-0.3.1-8.fc19
Comment 2 Fedora Update System 2013-08-31 20:00:50 EDT
Package libcmis-0.3.1-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libcmis-0.3.1-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15609/libcmis-0.3.1-8.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-09-08 19:26:17 EDT
libcmis-0.3.1-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.