Bug 1000909 - About High-Availability and Load Balancing Clusters subsystem list is awkward/wrong
About High-Availability and Load Balancing Clusters subsystem list is awkward...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: EAP 6.1.1
Assigned To: Misty Stanley-Jones
James Livingston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 01:45 EDT by James Livingston
Modified: 2016-02-21 19:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.11 Build Name: 11865, Administration and Configuration Guide-6.1-4 Build Date: 12-07-2013 01:29:20 Topic ID: 4647-458839 [Specified]
Last Closed: 2013-09-16 16:28:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Livingston 2013-08-26 01:45:50 EDT
Title: About High-Availability and Load Balancing Clusters


The list of subsystems which can be made highly available is awkward and partially incorrect.

1) It lists "JNDI services", but EAP 6 does not support HA JNDI.
2) "Some of the subsystems that can be made highly available are: Instances of the Application Server  ..." sounds strange, as instances of the server aren't subsystems of the server.
3) "Some of the subsystems that can be made highly available are: ... The web server, whether it is the internal JBoss Web server, Apache HTTPD, Microsoft IIS, Oracle iPlanet Web Server, or Apache Tomcat  ..." is again strange as they aren't subsystems. They are programs which can be used to make the web container highly available.
4) HTTP sessions - these can be made highly available, but they're not really a subsystem.


Aside from any other changes, it might be better to use a different word than "subsystem", since that has a specific meaning in the context of JBoss configuration. "Components" maybe?
Comment 2 Jan Martiska 2013-08-29 06:50:58 EDT
I assume the fix should be here in 6.1.1 doc: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Enterprise_Application_Platform/6.1.1/html/Administration_and_Configuration_Guide/chap-HTTP_Clustering_and_Load_Balancing.html#About_High-Availability_and_Load_Balancing_Clusters

(this is the place where QA verifies documentation changes, not docbuilder)
But no change is visible there. Also, after 2 days I don't see any change on the docbuilder link either.  Please set to ON_QA once the change is visible on documentation stage.
Comment 3 Misty Stanley-Jones 2013-08-29 22:14:39 EDT
Jan, this is flagged for 6.2, not 6.1.1. Sorry for the confusion.
Comment 5 Jan Martiska 2013-08-30 02:37:55 EDT
Flagged for 6.2 - ok, but I think there is no reason to not fix it in 6.1.1 too :)
Comment 9 Jan Martiska 2013-09-02 03:11:09 EDT
Seems ok to me now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.