Bug 1000914 - SizeNotPositiveError: spec= param must be >=0
SizeNotPositiveError: spec= param must be >=0
Status: CLOSED DUPLICATE of bug 997690
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:6e2b368fb8e7be426411b0c0426...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 02:02 EDT by Chuck Forsberg
Modified: 2013-08-26 15:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 14:48:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (456.71 KB, text/plain)
2013-08-26 02:02 EDT, Chuck Forsberg
no flags Details
File: anaconda.log (5.81 KB, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: environ (441 bytes, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: lsblk_output (3.00 KB, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: os_info (281 bytes, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: program.log (47.49 KB, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: storage.log (149.20 KB, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: syslog (104.36 KB, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details
File: packaging.log (9.15 KB, text/plain)
2013-08-26 02:03 EDT, Chuck Forsberg
no flags Details

  None (edit)
Description Chuck Forsberg 2013-08-26 02:02:55 EDT
Version-Release number of selected component:
anaconda-20.8-1

The following was filed automatically by anaconda:
anaconda 20.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 88, in _parseSpec
    raise SizeNotPositiveError("spec= param must be >=0")
  File "/usr/lib/python2.7/site-packages/blivet/size.py", line 138, in __new__
    self = Decimal.__new__(cls, value=_parseSpec(spec))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/lib/disks.py", line 82, in size_str
    return str(Size(spec=spec)).upper()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 218, in _update_labels
    text = _("Total selected space to reclaim: <b>%s</b>") % size_str(selectedReclaimable)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 453, in on_resize_value_changed
    self._update_labels(selectedReclaimable=self._selectedReclaimableSpace)
SizeNotPositiveError: spec= param must be >=0

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC1\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git4.1.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC1
Comment 1 Chuck Forsberg 2013-08-26 02:02:59 EDT
Created attachment 790287 [details]
File: anaconda-tb
Comment 2 Chuck Forsberg 2013-08-26 02:03:03 EDT
Created attachment 790288 [details]
File: anaconda.log
Comment 3 Chuck Forsberg 2013-08-26 02:03:06 EDT
Created attachment 790289 [details]
File: environ
Comment 4 Chuck Forsberg 2013-08-26 02:03:09 EDT
Created attachment 790290 [details]
File: lsblk_output
Comment 5 Chuck Forsberg 2013-08-26 02:03:13 EDT
Created attachment 790291 [details]
File: nmcli_dev_list
Comment 6 Chuck Forsberg 2013-08-26 02:03:17 EDT
Created attachment 790292 [details]
File: os_info
Comment 7 Chuck Forsberg 2013-08-26 02:03:20 EDT
Created attachment 790293 [details]
File: program.log
Comment 8 Chuck Forsberg 2013-08-26 02:03:24 EDT
Created attachment 790294 [details]
File: storage.log
Comment 9 Chuck Forsberg 2013-08-26 02:03:27 EDT
Created attachment 790295 [details]
File: syslog
Comment 10 Chuck Forsberg 2013-08-26 02:03:31 EDT
Created attachment 790296 [details]
File: ifcfg.log
Comment 11 Chuck Forsberg 2013-08-26 02:03:35 EDT
Created attachment 790297 [details]
File: packaging.log
Comment 12 David Shea 2013-08-26 14:48:21 EDT

*** This bug has been marked as a duplicate of bug 997690 ***

Note You need to log in before you can comment on or make changes to this bug.