Bug 1000920 - [RFE] Support PPC and ARM builds
[RFE] Support PPC and ARM builds
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
: FutureFeature
Depends On:
Blocks: FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64 F-ExcludeArch-ARM F-ExcludeArch-ppc
  Show dependency treegraph
 
Reported: 2013-08-26 02:29 EDT by Fabian Deutsch
Modified: 2014-06-11 09:53 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-11 09:53:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-08-26 02:29:53 EDT
Description of problem:
ovirt-node currently doesn't build on PPC/ARM because some requirements are not available on these platforms.
Comment 1 Ramon Medeiros 2013-09-03 11:44:17 EDT
What requirements are not available. Can I help?
Comment 2 Ramon Medeiros 2013-09-03 11:45:21 EDT
I'm looking for PPC support!
Comment 3 Fabian Deutsch 2013-09-03 11:46:49 EDT
Hey Ramon,

the reason is that some dependencies are not available on ARM (dunno about PPC).
E.g. libvirt cim or so it was.

Additionally - at least on arm - the installation will probably fail as it is tied to grub2?.
Comment 4 Mike Burns 2013-09-03 12:35:57 EDT
(In reply to Fabian Deutsch from comment #3)
> Hey Ramon,
> 
> the reason is that some dependencies are not available on ARM (dunno about
> PPC).
> E.g. libvirt cim or so it was.

Yes, libvirt-cim is not available on ARM

> 
> Additionally - at least on arm - the installation will probably fail as it
> is tied to grub2?.

grub2 causes build failures as well since we "require" grub2 in our base ovirt-node package.


As for PPC, it's not a primary architecture on Fedora (AFAIK).  The main problem here is that we depend on qemu-kvm which is not available on ppc.
Comment 5 Gustavo Luiz Duarte 2013-12-02 10:42:41 EST
(In reply to Mike Burns from comment #4)
> As for PPC, it's not a primary architecture on Fedora (AFAIK).  The main
> problem here is that we depend on qemu-kvm which is not available on ppc.

qemu-kvm is available on ppc64: http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=208990

*Running* KVM on PPC64 requires special hardware with KVM support though.

libvirt-cim and grub2 are also available on Fedora ppc64.
Comment 6 Doron Fediuck 2014-06-11 09:53:03 EDT
We're considering a different node implementation for oVirt 4.0.
Hence, closing this RFE. Please re-open if relevant.

Note You need to log in before you can comment on or make changes to this bug.