Bug 1000921 - BVT: glusterfs packages installation are failing in Beaker
BVT: glusterfs packages installation are failing in Beaker
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Amar Tumballi
Lalatendu Mohanty
:
Depends On: 1000500
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 02:31 EDT by Lalatendu Mohanty
Modified: 2013-12-18 19:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-08-26 02:31:59 EDT
Description of problem:

Glusterfs packages installation are failing in Beaker because of below error

Installing glusterfs-libs-3.4.0.22rhs-1377267009.el6.x86_64
error: %pretrans(glusterfs-libs-3.4.0.22rhs-1377267009.el6.x86_64) scriptlet failed, exit status 127

Version-Release number of selected component (if applicable):
glusterfs-libs-3.4.0.22rhs

How reproducible:
Always

Steps to Reproduce:
1. use the BVT repo to install a RHI ISO
2. Check the install.log
3.

Actual results:


Expected results:


Additional info:

Beaker installation with nightly rhs rpms is equivalent to a fresh ISO installation. So the issue I am seeing now will be seen when we will get latest ISO with glusterfs-libs-3.4.0.22rhs.

Below is the content of Beaker job.xml

<recipe kernel_options="selinux=0" kernel_options_post="selinux=0" ks_meta="" role="RECIPE_MEMBERS" whiteboard="">
			<autopick random="false"/>
			<watchdog panic="ignore"/>
			<packages/>
			<ks_appends/>
			<repos>
				<repo name="rhs" url="http://rhsqe-repo.lab.eng.blr.redhat.com/bvt-qe/"/>
			</repos>
			<distroRequires>
				<and>
					<distro_family op="=" value="RedHatStorage2"/>
					<distro_variant op="=" value="RHS"/>
					<distro_name op="=" value="RHS-2.1-20130820.n.0"/>
					<distro_arch op="=" value="x86_64"/>
				</and>
			</distroRequires>
			<hostRequires>
				<and>
					<hostname op="=" value="rhsauto019.lab.eng.blr.redhat.com"/>
					<system_type op="=" value="Machine"/>
				</and>
			</hostRequires>
			<partitions/>
			<task name="/distribution/install" role="STANDALONE">
				<params/>
			</task>
Comment 1 Lalatendu Mohanty 2013-08-26 02:34:43 EDT
This issie looks similar to issue reported in https://bugzilla.redhat.com/show_bug.cgi?id=1000500

But the above bug is for RHEVH+gluster and thsi bug is for tacking the BVT issue.
Comment 4 Lalatendu Mohanty 2013-08-26 05:40:43 EDT
Started a new run from Jenkins which involves (creating rpms from downstream code and running beaker jobs ) and the installation got completed successfully.

Hence marking the bug as verified.
https://beaker.engineering.redhat.com/jobs/479936
Comment 5 Scott Haines 2013-09-23 18:25:02 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.