Bug 1000927 - 20 Alpha TC1 i386 install image (netinst or DVD) freezes in the first step
20 Alpha TC1 i386 install image (netinst or DVD) freezes in the first step
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-08-26 02:59 EDT by Tao Wu
Modified: 2014-10-28 19:46 EDT (History)
22 users (show)

See Also:
Fixed In Version: anaconda-20.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 22:40:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (90.20 KB, image/png)
2013-08-26 03:02 EDT, Tao Wu
no flags Details
anaconda log (2.51 KB, text/plain)
2013-08-26 03:04 EDT, Tao Wu
no flags Details
cpu occupies (16.78 KB, image/png)
2013-08-28 05:43 EDT, Tao Wu
no flags Details
backtrace (4.53 KB, text/plain)
2013-09-03 11:28 EDT, David Shea
no flags Details

  None (edit)
Description Tao Wu 2013-08-26 02:59:38 EDT
Description of problem:
When I install the F20 netinst in the kvm, it just suspend at the first step, after selecting the language.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Tao Wu 2013-08-26 03:02:20 EDT
Created attachment 790310 [details]
screen shot
Comment 2 Tao Wu 2013-08-26 03:04:41 EDT
Created attachment 790311 [details]
anaconda log
Comment 3 Andre Robatino 2013-08-26 05:30:23 EDT
Happens with either 32-bit install image (netinst or DVD). 64-bit images are not affected.
Comment 4 Kamil Páral 2013-08-27 12:13:20 EDT
Tao, do you mean suspend (a.k.a put to sleep) or freeze? I can reproduce freeze. anaconda process is at 100% cpu.

When I switch to tty1, I see:
error: XDG_RUNTIME_DIR not set in the environment.

Proposing as AlphaBlocker:
The installer must run when launched normally from the release-blocking images. 
https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Installer_must_run
Comment 5 Tao Wu 2013-08-28 05:41:51 EDT
(In reply to Kamil Páral from comment #4)
> Tao, do you mean suspend (a.k.a put to sleep) or freeze? I can reproduce
> freeze. anaconda process is at 100% cpu.
> 
> When I switch to tty1, I see:
> error: XDG_RUNTIME_DIR not set in the environment.
> 
> Proposing as AlphaBlocker:
> The installer must run when launched normally from the release-blocking
> images. 
> https://fedoraproject.org/wiki/
> Fedora_20_Alpha_Release_Criteria#Installer_must_run

Kamil, I am not sure that it does freeze. In my case, the anaconda takes up about 90% cpu like the attachment displays.
Comment 6 Tao Wu 2013-08-28 05:43:02 EDT
Created attachment 791288 [details]
cpu occupies
Comment 7 Kamil Páral 2013-08-28 06:16:35 EDT
(In reply to Tao Wu from comment #6)
> Created attachment 791288 [details]
> cpu occupies

Since it already consumed 1158 minutes of CPU time, I think you can very well consider it frozen (or stuck or whatever you want to call it) :-)
Comment 8 Kamil Páral 2013-08-28 12:12:41 EDT
Discussed at 2013-08-28 blocker review meeting [1]. This is accepted as an Alpha blocker, because it violates the following F20 alpha release criterion for 32bit installs: "When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-08-28/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Remote_package_sources
Comment 9 Orion Poplawski 2013-08-28 12:40:48 EDT
I get the same thing with a kickstart install on physical hardware.  Hangs for me during "Starting package installation process" just after clicking "Yes" to skipping the missing package "unrar".  strace of the anaconda process shows:

5309  futex(0x97aff70, FUTEX_WAIT_PRIVATE, 0, NULL <unfinished ...>
5287  restart_syscall(<... resuming interrupted call ...> <unfinished ...>
5098  --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x37c7} ---
5176  restart_syscall(<... resuming interrupted call ...> <unfinished ...>
5098  sigreturn() (mask [])             = 14279
5098  --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x37c7} ---
5098  sigreturn() (mask [])             = 14279
5098  --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x37c7} ---
..........

the last two lines repeat forever.

last anaconda.log lines:

16:26:32,541 INFO anaconda: Setting up the installation environment
16:26:40,828 INFO anaconda: Creating ext4 on /dev/sda5
16:26:59,393 INFO anaconda: Creating swap on /dev/sda3
16:27:00,592 INFO anaconda: Creating biosboot on /dev/sda2

packaging.log shows:

16:28:19,545 DEBUG packaging: select package unrar
16:28:19,549 INFO packaging: about to acquire _yum_lock for AnaInstallThread at /usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py:1157 (_applyYumSelections)
16:28:19,550 INFO packaging: have _yum_lock for AnaInstallThread
16:28:19,552 DEBUG yum.verbose.YumBase: Checking for virtual provide or file-provide for unrar
16:28:19,555 INFO packaging: gave up _yum_lock for AnaInstallThread
Comment 10 Tao Wu 2013-08-29 00:42:42 EDT
This bug still exists in Tc2 i386, on my kvm.
Comment 11 Robert Lightfoot 2013-08-31 22:01:13 EDT
I am seeing this bug in Alpha-TC2 and on tty1 it is reporting "error: XDG_RUNTIME_DIR not set in environment"  Could this bug be as simple as an undeclared environment variable?
Comment 12 Vratislav Podzimek 2013-09-03 07:29:07 EDT
David, could you please have a look at this one? If I comment out the 'with englightbox(...):' line in _on_continue_clicked in pyanaconda/ui/gui/spokes/welcome.py, everything works as expected. Some debugging shows that the SIGSEGV happens when AnacondaWidgets.lb_destroy(lightbox) is called. However, since this happens only in 32bit installations, I doubt it is a problem on our side.
Comment 13 David Shea 2013-09-03 11:28:31 EDT
Created attachment 793239 [details]
backtrace
Comment 14 David Shea 2013-09-03 11:34:09 EDT
This appears to be a problem in glib. The crash is happening at this line in lightbox.c:

g_signal_emit_by_name(window, "configure-event", window);

which is causing value_lcopy_boolean to write to an invalid pointer.

The window has not been destroyed and GTK_IS_WINDOW(window) returns true. I've attached the backtrace for the g_signal_emit_by_name call and below.
Comment 15 Tao Wu 2013-09-04 23:14:54 EDT
Unfortunately it still happens on F20 TC3.
Comment 16 Matthias Clasen 2013-09-05 09:36:58 EDT
Doesn't look glib related to me at all. Where does the code for lightbox.c live ? Thats the most likely culprit.
Comment 17 Kamil Páral 2013-09-05 09:41:55 EDT
Changing needinfo to David.
Comment 18 Matthias Clasen 2013-09-05 09:55:21 EDT
The relevant anaconda code [1] says

            /* XXX HAAAAAAACK: */

So, I'd go looking there first.


[1] https://git.fedorahosted.org/cgit/anaconda.git/tree/widgets/src/lightbox.c
Comment 19 Matthias Clasen 2013-09-05 10:00:09 EDT
Fixing the signal emission [1] to actually match the signature of the configure-event signal [2] may fix the crash. But the code should still not do that kind of thing, it is not at all kosher to emit gtks internal signals willy-nilly like that.

[1] https://developer.gnome.org/gobject/2.36/gobject-Signals.html#g-signal-emit-by-name
[2] https://developer.gnome.org/gtk3/3.8/GtkWidget.html#GtkWidget-configure-event
Comment 20 Andre Robatino 2013-09-05 16:30:25 EDT
Still broken in 20 Alpha TC4 i386 install images (netinst or DVD). x86_64 install images are ok as before.
Comment 21 Tao Wu 2013-09-06 06:12:45 EDT
Still happens in F20 Alpha TC4 i386.
Comment 22 Jaroslav Reznik 2013-09-06 09:09:37 EDT
David/Vratislav, 
did you have time to take a look on proposed fix by Matthias?
Comment 23 David Shea 2013-09-06 17:38:06 EDT
Here are some updates images for anyone who wants to test:

32-bit: http://dshea.fedorapeople.org/updates-1000927-i386.img
64-bit: http://dshea.fedorapeople.org/updates-1000927-x86_64.img
Comment 24 Robert Lightfoot 2013-09-06 21:45:26 EDT
(In reply to David Shea from comment #23)
> Here are some updates images for anyone who wants to test:
> 
> 32-bit: http://dshea.fedorapeople.org/updates-1000927-i386.img
> 64-bit: http://dshea.fedorapeople.org/updates-1000927-x86_64.img

Will this update be in alpha_tc5 or do we need to test the updates against tc4?
Comment 25 Andre Robatino 2013-09-07 05:19:35 EDT
(In reply to David Shea from comment #23)
> Here are some updates images for anyone who wants to test:
> 
> 32-bit: http://dshea.fedorapeople.org/updates-1000927-i386.img
> 64-bit: http://dshea.fedorapeople.org/updates-1000927-x86_64.img

Using these, all four 20 Alpha TC4 install images (32- and 64-bit DVD and netinst) successfully get to the "Installation Summary" page. (Unfortunately, if the Installation source is set to "Closest mirror", there's an "Error checking software selection" error when trying to do a default GNOME install, but that's a separate bug - it happens either with or without the updates.img.)
Comment 26 Tao Wu 2013-09-08 22:24:59 EDT
This still happens in TC5, but can work around through David Shea's updates img. Thanks to David Shea.
Comment 27 Petr Schindler 2013-09-09 02:39:22 EDT
Setting status and component back to right value.
Comment 28 Jaroslav Reznik 2013-09-10 07:20:58 EDT
Can we get the patch review + build done today?
Comment 29 Jaroslav Reznik 2013-09-10 08:40:46 EDT
(In reply to Jaroslav Reznik from comment #28)
> Can we get the patch review + build done today?

Review done, as a temporary solution for Alpha. Thanks Vratislav.
Comment 30 Fedora Update System 2013-09-10 15:48:04 EDT
anaconda-20.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.14-1.fc20
Comment 31 Fedora Update System 2013-09-11 12:56:57 EDT
Package anaconda-20.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16409/anaconda-20.14-1.fc20
then log in and leave karma (feedback).
Comment 32 Tim Flink 2013-09-11 14:35:52 EDT
tested with f20 alpha RC1 i386 on a VM, install completes successfully.

Setting to VERIFIED
Comment 33 Fedora Update System 2013-09-11 21:02:56 EDT
anaconda-20.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.15-1.fc20
Comment 34 Fedora Update System 2013-09-13 21:04:47 EDT
anaconda-20.16-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.16-1.fc20
Comment 35 Fedora Update System 2013-09-16 13:47:40 EDT
anaconda-20.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.17-1.fc20
Comment 36 Robert Lightfoot 2013-09-16 15:38:09 EDT
This problem no longer exists in Alpha_RC2
Comment 37 Fedora Update System 2013-09-18 22:40:26 EDT
anaconda-20.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.