Bug 1000932 - Evolution begin consume 100% CPU and hang
Evolution begin consume 100% CPU and hang
Status: CLOSED DUPLICATE of bug 998866
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 03:07 EDT by Mikhail
Modified: 2013-08-26 10:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 10:04:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
htop screenshot (242.48 KB, image/png)
2013-08-26 03:07 EDT, Mikhail
no flags Details
Evolution backtrace (3.09 KB, application/x-bzip)
2013-08-26 03:09 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2013-08-26 03:07:54 EDT
Created attachment 790312 [details]
htop screenshot

Description of problem:
Evolution begin consume 100% CPU and hang
Comment 1 Mikhail 2013-08-26 03:09:37 EDT
Created attachment 790313 [details]
Evolution backtrace
Comment 2 Mikhail 2013-08-26 03:10:29 EDT
[mikhail@telecon-17-afbank-ru ~]$ evolution
No bp log location saved, using default.
[000:000] Browser XEmbed support present: 1
[000:000] Browser toolkit is Gtk2.
[000:001] Using Gtk2 toolkit
No bp log location saved, using default.
[000:141] No bp log location saved, using default.
[000:141] Browser XEmbed support present: 1
[000:141] Browser toolkit is Gtk2.
[000:141] Using Gtk2 toolkit
[000:000] No bp log location saved, using default.

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x92fc000 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x92fc000 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x92fc000 is mapped but visible=0 child_visible=1 parent GtkBox 0x989a190 mapped=1

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x92fc000 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x92fc000 is mapped but visible=0 child_visible=1 parent GtkBox 0x989a190 mapped=1

(evolution:1661): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:1661): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:1661): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:1661): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:1661): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d1c0 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d1c0 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d1c0 is mapped but visible=0 child_visible=1 parent GtkBox 0xa5362d8 mapped=1

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d1c0 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d1c0 is mapped but visible=0 child_visible=1 parent GtkBox 0xa5362d8 mapped=1

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/livejournal.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/vk.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/twitter.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/1.png (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/odnoklassniki.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/facebook.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/1.png (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/twitter.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/vk.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/facebook.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/odnoklassniki.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/livejournal.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/1.png (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/facebook.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/twitter.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/livejournal.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/odnoklassniki.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/vk.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/1.png (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/facebook.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/vk.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/odnoklassniki.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/twitter.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/livejournal.gif (code 4)

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d000 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d000 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d000 is mapped but visible=0 child_visible=1 parent GtkBox 0x97de168 mapped=1

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d000 is mapped but not visible

(evolution:1661): Gtk-WARNING **: EAttachmentBar 0x9c3d000 is mapped but visible=0 child_visible=1 parent GtkBox 0x97de168 mapped=1

** (evolution:1661): CRITICAL **: e_mail_part_list_ref_part: assertion `E_IS_MAIL_PART_LIST (part_list)' failed
Created new window in existing browser session.
Created new window in existing browser session.

(evolution:1661): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:1661): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:1661): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:1661): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:1661): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/facebook.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/livejournal.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/1.png (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/odnoklassniki.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/vk.gif (code 4)

(evolution:1661): evolution-mail-WARNING **: Failed to request http://bashkortostan-resp.job.ru/library/image/mail/massmail/twitter.gif (code 4)
Created new window in existing browser session.
Created new window in existing browser session.

** (evolution:1661): CRITICAL **: e_mail_part_list_ref_part: assertion `E_IS_MAIL_PART_LIST (part_list)' failed
error: The metadata does not have a thumbnail property

(evolution:1661): GnomeDesktop-WARNING **: Unable to create loader for mime type application/msword: Unrecognized image file format

(evolution:1661): GnomeDesktop-WARNING **: Error creating thumbnail for file:///home/mikhail/Documents/%D0%94%D0%B5%D0%BD%D1%8C%20%D0%BE%D1%82%D0%B4%D1%8B%D1%85%D0%B0.doc: Unrecognized image file format
^C
Comment 3 Milan Crha 2013-08-26 10:04:08 EDT
Thanks for a bug report. It's like yours bug #998866, the backtrace doesn't show any activity in evolution, all threads are idle.

Ideally, if you could find some steps to reproduce this, and maybe provide data. I guess  it's some message which triggers this CPU usage, and probably some plugin. As I wrote in the other bug report, you seem to have installed some browser plugins which can cause the misbehaviour. I do not recall seeing such console messages from your evolution in Fedora 18, where is also used webkit for rendering. There seemed evolution more stable for you, but I do not see instability in Fedora 19 like you, while I also have EWS account turned on, thus the difference I see is with plugins (and/or other libraries you might be using).

*** This bug has been marked as a duplicate of bug 998866 ***

Note You need to log in before you can comment on or make changes to this bug.