Bug 1000981 - Packstack fails when defining bridge_mapping to the external bridge due to duplicate definition of puppet resource
Packstack fails when defining bridge_mapping to the external bridge due to du...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 4.0
Assigned To: Terry Wilson
Rami Vaknin
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 05:03 EDT by Rami Vaknin
Modified: 2016-04-26 12:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: Packstack would attempt to set up the br-ex bridge twice if the br-ex bridge was included in a bridge mapping. Consequence: Packstack installation would fail. Fix: Packstack now detects whether br-ex is included in a bridge mapping and delays creating br-ex until the bridge mapping stage. Result: Packstack no longer fails when br-ex is used in a bridge mapping.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:21:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 60382 None None None Never

  None (edit)
Description Rami Vaknin 2013-08-26 05:03:21 EDT
Version:
Grizzly on RHEL6.4
openstack-packstack-2013.1.1-0.30.dev672.el6ost.noarch
openstack-quantum-2013.1.3-1.el6ost.noarch


Description:
Packstack fails when defining bridge_mapping to the external bridge:

ERROR : Error during puppet run : Duplicate definition: Vs_bridge[br-ex] is already defined in file /var/tmp/packstack/c439a9dee62040eeaf5f231a1d4f9520/manifests/10.35.160.27_quantum.pp at line 37; cannot redefine at /var/tmp/packstack/c439a9dee62040eeaf5f231a1d4f9520/modules/quantum/manifests/plugins/ovs/bridge.pp:8 on node puma09.scl.lab.tlv.redhat.com


Neutron-related keys in Packstack's answer file
===============================================

CONFIG_QUANTUM_INSTALL=y
CONFIG_QUANTUM_SERVER_HOST=10.35.160.29
CONFIG_QUANTUM_USE_NAMESPACES=y
CONFIG_QUANTUM_KS_PW=123456
CONFIG_QUANTUM_DB_PW=123456
CONFIG_QUANTUM_L3_HOSTS=10.35.160.27
CONFIG_QUANTUM_L3_EXT_BRIDGE=br-ex
CONFIG_QUANTUM_DHCP_HOSTS=10.35.160.25
CONFIG_QUANTUM_L2_PLUGIN=openvswitch
CONFIG_QUANTUM_METADATA_HOSTS=10.35.160.29
CONFIG_QUANTUM_METADATA_PW=123456
CONFIG_QUANTUM_LB_TENANT_NETWORK_TYPE=local
CONFIG_QUANTUM_LB_VLAN_RANGES=
CONFIG_QUANTUM_LB_INTERFACE_MAPPINGS=
CONFIG_QUANTUM_OVS_TENANT_NETWORK_TYPE=vlan
CONFIG_QUANTUM_OVS_VLAN_RANGES=int_vlan_range:211:214,ext_vlan_range:185:185
CONFIG_QUANTUM_OVS_BRIDGE_MAPPINGS=int_vlan_range:br-vlans,ext_vlan_range:br-ex
CONFIG_QUANTUM_OVS_BRIDGE_IFACES=


From Packstack's log file
=========================

2013-08-26 11:43:11::ERROR::ospluginutils::143::root:: Error  during remote puppet apply of /var/tmp/packstack/20130826-114126-Ym0xpl/manifests/10.35.160.27_quantum.pp
2013-08-26 11:43:11::ERROR::ospluginutils::144::root:: Duplicate definition: Vs_bridge[br-ex] is already defined in file /var/tmp/packstack/c439a9dee62040eeaf5f231a1d4f9520/manifests/10.35.160.27_quantum.pp at line 37; cannot redefine at /var/tmp/packstack/c439a9dee62040eeaf5f231a1d4f9520/modules/quantum/manifests/plugins/ovs/bridge.pp:8 on node puma09.scl.lab.tlv.redhat.com

2013-08-26 11:43:11::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 908, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : Duplicate definition: Vs_bridge[br-ex] is already defined in file /var/tmp/packstack/c439a9dee62040eeaf5f231a1d4f9520/manifests/10.35.160.27_quantum.pp at line 37; cannot redefine at /var/tmp/packstack/c439a9dee62040eeaf5f231a1d4f9520/modules/quantum/manifests/plugins/ovs/bridge.pp:8 on node puma09.scl.lab.tlv.redhat.com


From 10.35.160.27_quantum.pp source file
========================================

vs_bridge { 'br-ex':
  ensure => present,
  require => Service['quantum-plugin-ovs-service']
}


From /usr/lib/python2.6/site-packages/packstack/puppet/modules/quantum/manifests/plugins/ovs/bridge.pp source file
==================================================================================================================

define quantum::plugins::ovs::bridge {
  $mapping = split($name, ':')
  $bridge = $mapping[1]

  vs_bridge {$bridge:
    ensure       => present,
    external_ids => "bridge-id=${bridge}"
  }
}
Comment 5 Rami Vaknin 2013-12-11 13:17:51 EST
Verified on rhos 4.0 running on rhel 6.5 with 2013-12-09.2 puddle, openstack-packstack-2013.2.1-0.14.dev919.el6ost.

Now packstack pass successfully when mapping the vlan range to br-ex.

CONFIG_NEUTRON_INSTALL=y
CONFIG_NEUTRON_SERVER_HOST=10.35.160.29
CONFIG_NEUTRON_KS_PW=123456
CONFIG_NEUTRON_DB_PW=123456
CONFIG_NEUTRON_L3_HOSTS=10.35.160.29
CONFIG_NEUTRON_L3_EXT_BRIDGE=br-ex
CONFIG_NEUTRON_DHCP_HOSTS=10.35.160.27
CONFIG_NEUTRON_LBAAS_HOSTS=10.35.160.29
CONFIG_NEUTRON_L2_PLUGIN=openvswitch
CONFIG_NEUTRON_METADATA_HOSTS=10.35.160.29
CONFIG_NEUTRON_METADATA_PW=123456
CONFIG_NEUTRON_LB_TENANT_NETWORK_TYPE=local
CONFIG_NEUTRON_LB_VLAN_RANGES=
CONFIG_NEUTRON_LB_INTERFACE_MAPPINGS=
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=vlan
CONFIG_NEUTRON_OVS_VLAN_RANGES=int_vlan_range:211:214,ext_vlan_range:185:185
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=int_vlan_range:br-nodes,ext_vlan_range:br-ex
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=
CONFIG_NEUTRON_OVS_TUNNEL_IF=
Comment 7 errata-xmlrpc 2013-12-19 19:21:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.