Bug 1000990 - Undefined option -i in mount.nfs help usage info
Undefined option -i in mount.nfs help usage info
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.4
All Linux
low Severity low
: rc
: ---
Assigned To: Steve Dickson
ChunYu Wang
:
Depends On: 1000989
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 05:22 EDT by Yin.JianHong
Modified: 2017-03-21 07:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-73.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1000989
Environment:
Last Closed: 2017-03-21 07:22:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-08-26 05:22:24 EDT
This bug was initially created as a clone of Bug #1000989

Description of problem:
Undefined option -i  in  mount.nfs help usage info

Version-Release number of selected component (if applicable):
RedHatEnterpriseWorkstation 6.4
nfs-utils-1.2.3-36.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. mount.nfs -h
2.
3.

Actual results:
# mount.nfs -h
usage: mount.nfs remotetarget dir [-rvVwfnsih] [-o nfsoptions]
                                           `---here 'i' not define in follow and man mount.nfs page;
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, do not actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than fail
        -h              Print this help
        nfsoptions      Refer to mount.nfs(8) or nfs(5)

Expected results:
# mount.nfs -h
usage: mount.nfs remotetarget dir [-rvVwfnsh] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, do not actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than fail
        -h              Print this help
        nfsoptions      Refer to mount.nfs(8) or nfs(5)

Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 22:33:54 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Steve Whitehouse 2015-12-11 13:25:48 EST
I wonder if we could not not combine all these mount/umount.nfs help text bugs into one, and fix them all in one go.
Comment 9 ChunYu Wang 2016-12-25 22:26:35 EST
Moving to VERIFIED according comment #7 and comment #8.

Will keep watching on this issue before 6.9 delivered.
Comment 11 errata-xmlrpc 2017-03-21 07:22:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0741.html

Note You need to log in before you can comment on or make changes to this bug.