Bug 1000994 - reason why it stays on 2.8.1 forever?
reason why it stays on 2.8.1 forever?
Status: CLOSED DUPLICATE of bug 1049219
Product: Fedora
Classification: Fedora
Component: libzdb (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 05:35 EDT by Harald Reindl
Modified: 2014-01-09 01:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-09 01:49:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-08-26 05:35:52 EDT
why did libzdb got the last update on 2011-02-23 and after
that only automatic mass-rebuilds?
__________________________________

libzdb-2.11.3-10.fc18.20130826.rh.x86_64

                         CHANGES version 2.11.3

              This file summarizes changes made since 1.0
              
Version 2.11.3
--------------
* New: License exception added to allow for linking and 
  distributing this Software together with OpenSSL.

Version 2.11.2
--------------
* New: Throw SQLException if a database access error occurs
  when ResultSet_next() is called. Previously, access errors
  could be masked as end of result set. Thanks to JiaQiang Xu.
* Fixes: Possible mem leak in Oracle's blob operation fixed 
  (Volodymyr Tarasenko)

Version 2.11.1
--------------
* Fixes: MySQL: Fixed a ResultSet bind memory error which could occur
  if string or blob columns of different size caused successive buffer
  reallocation. Thanks to Ryan Addams for discovering the problem.

Version 2.11
------------
* New: Added support for the new bytea hex encoding format
  introduced in PostgreSQL 9.0.
* Fixes: MySQL: A table with two or more columns larger than 256
  bytes would cause libzdb to truncate the second column to 256 
  bytes in the first row. Thanks to Me from China for bug report
  and patch.
* Fixes: Using configure flags --with-xxx without arguments
  now works as expected. Thanks to Johan Bergström for report

Version 2.10.6
--------------
* New: ConnectionPool_start() now throws an SQLException instead
  of calling ABORT if starting the pool failed. Thanks to
  Christopher O'Hara for suggestion.
* Fixes: MySQL: Using a stored procedure which returned a
  result set would freeze the connection until it was reaped.
  Thanks to Jesse White for patch.
* Fixes: Ensure that the library can be restarted after it was 
  stopped without leaking resources. Only applicable for MySQL
  which could leak memory on runtime restart. Thanks to Axel 
  Steiner for initial patch and suggestion.

Version 2.10.5
--------------
* New: Automatically unescape the following URL components:
  credentials, path and parameter values.

Version 2.10.4
--------------
* MySQL: Improved error reporting for select and prepared statements

Version 2.10.3
--------------
Bug fixes: Oracle: fixed a compile issue for GCC when strict
C99 is used. Thanks to Stas Oginsky.

Version 2.10.2
--------------
Bug fixes: Oracle: fixed a parameter sequence bug at
connection. Bug was introduced in 2.9. Thanks to l00106600.

Version 2.10.1
--------------
* A zdb.pc library package config file was added. Thanks to 
  Matthieu Verbert
* Build, configure and minor code improvements

Version 2.10
-----------
* Libzdb is now compatible with and can be included in C++ or 
  Objective-C(++) projects.
* Internal optimising changes and improvements

Version 2.9
-----------
* SQLite: Unescape path to allow for (white-)space in database file
  path. Thanks to Jonas Schnelli
* SQLite: Use sqlite3_open_v2 instead of sqlite3_enable_shared_cache 
  which is deprecated in OS X Lion. 
* Oracle: Fixed a problem with ResultSet not returning all data
Comment 1 Christopher Meng 2014-01-09 01:49:31 EST
Because the maintainer is in Z(zombie) mode.

I'm going to take over the ownership.

*** This bug has been marked as a duplicate of bug 1049219 ***

Note You need to log in before you can comment on or make changes to this bug.