Bug 1001030 - [rhevm] Backend - VM Bootable vDisk is changed when adding the third vDisk
[rhevm] Backend - VM Bootable vDisk is changed when adding the third vDisk
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: nobody nobody
Aharon Canan
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 07:14 EDT by David Botzer
Modified: 2016-02-10 13:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-01 09:39:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pic (92.81 KB, image/png)
2013-08-26 07:14 EDT, David Botzer
no flags Details
engine (179.26 KB, application/x-gzip)
2013-08-26 07:15 EDT, David Botzer
no flags Details
vdsm (836.56 KB, application/x-gzip)
2013-08-26 07:15 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2013-08-26 07:14:04 EDT
Created attachment 790429 [details]
pic

Description of problem:
[rhevm] Backend - VM Bootable vDisk is changed when adding the third vDisk

Version-Release number of selected component (if applicable):
3.3/is11

How reproducible:
always

Steps to Reproduce:
1.create vm with 1 disk
2.add 2 vDisk
3.Start VM

Actual results:
VM cannot boot, since its bootable disk was changed

Expected results:
Bootable vDisk should change when adding additional disks

Additional info:
Workaround - 
Stop the VM and edit the vDisk it to be bootable
Comment 1 David Botzer 2013-08-26 07:15:08 EDT
Created attachment 790430 [details]
engine
Comment 2 David Botzer 2013-08-26 07:15:30 EDT
Created attachment 790431 [details]
vdsm
Comment 3 Itamar Heim 2013-08-27 03:20:19 EDT
david - how is this infra? its either storage or virt
setting storage since they are tackling disk boot order in another bug.
Comment 4 David Botzer 2013-09-01 09:39:35 EDT
David:
With Blank VM its not reproducible
The first & only disk in the template is not marked as Bootable, but contains the OS and vm starts ok,
--------------------
I have a template with 1 disk.
A VM created from template (Thin/Clone) has 1 disk which is marked as not-bootable therefore each new disk suggested to be bootable (check box is "is bootable" is enabled)

Note You need to log in before you can comment on or make changes to this bug.