Bug 1001044 - Unable to create access-log for virtual server
Unable to create access-log for virtual server
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Rémy Maucherat
Radim Hatlapatka
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 07:53 EDT by Radim Hatlapatka
Modified: 2013-12-15 08:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 06:46:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2013-08-26 07:53:43 EDT
Description of problem:
I am unable to create access log via CLI for virtual server

Version-Release number of selected component (if applicable):
Tested with EAP 6.1.1.ER7

How reproducible: always


Steps to Reproduce:
1. start EAP and connect via CLI
2. /subsystem=web/virtual-server=default-host/access-log=test:add()

Actual results:
outcome failed with failure-description = "JBAS014883: No resource definition is registered"  


Expected results:
outcome success with created default access-log configuration as from schema no attributes seems mandatory and have default values

Additional info:
There is also no code completion for any operation regarding access-log
Comment 2 Radim Hatlapatka 2013-09-13 06:46:49 EDT
Actually it is not a bug, you just need to use as the access-log=configuration:add in order to make it work. The "configuration" keyword is required.

Note You need to log in before you can comment on or make changes to this bug.