Bug 1001059 - Can't boot into init 1 on LiveCD
Can't boot into init 1 on LiveCD
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 08:27 EDT by Kamil Páral
Modified: 2013-08-29 09:28 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 09:28:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
password prompt (14.07 KB, image/png)
2013-08-26 08:27 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-08-26 08:27:30 EDT
Created attachment 790479 [details]
password prompt

Description of problem:
For a purpose of bug verification, I needed to boot F20 Live into init 1. That system has password-less root account, obviously, since it's a LiveCD. Unfortunately, system requests a password and simply hitting Enter doesn't work, it prints an "invalid argument" error.

I should be able to boot into init 1 with password-less root. Make the prompt accept no password.

Version-Release number of selected component (if applicable):
http://dl.fedoraproject.org/pub/alt/stage/20-Alpha-TC1/Live/x86_64/
systemd-206-6.fc20

How reproducible:
always

Steps to Reproduce:
1. boot the LiveCD with "1" and the end of kernel cmdline

Actual results:
can't log in

Expected results:
can log in

Additional info:
I wonder what happens if the root account is disabled...
Comment 1 Harald Hoyer 2013-08-26 09:13:44 EDT
$ fgrep ExecStart= /lib/systemd/system/rescue.service
ExecStart=-/sbin/sulogin

$ rpm -qf /sbin/sulogin 
util-linux-2.23.2-2.fc19.x86_64


sulogin should be able to cope with the empty password
Comment 2 Karel Zak 2013-08-27 06:46:22 EDT
Note that I'm not able to reproduce the problem with the latest RHEL7 (also util-linux 2.23.2-2) with empty root password in /etc/shadow.

... going to try it with F20 LiveCD.
Comment 3 Karel Zak 2013-08-29 07:39:39 EDT
I see 

  root:*:15921:0:99999:7:::

in LiveCD /etc/shadow. It's really not empty password, see shadow(5) man page for more details. The sulogin(1) command works as expected.

Reassigning...
Comment 4 Kamil Páral 2013-08-29 08:47:33 EDT
I just booted Fedora-Live-Desktop-x86_64-20-Alpha-TC1-1.iso and I see

root::15946:0:99999:7:::

in /etc/shadow. The password is empty. I can log in using "su -" or on tty2 without providing a password.

Karel, which LiveCD did you use?
Comment 5 Kamil Páral 2013-08-29 09:28:41 EDT
So, mystery solved by Karel Zak (thanks). Initially the LiveCD is created with a unusable root account (which is slightly different from locked, I guess). Then in an "livesys" initscript the root password is emptied. But if I boot to single user mode, the emergency password is asked before livesys is run, thus I can't provide the emergency password.

If we changed our kickstart in spin-kickstarts, we could create the LiveCD with no root password right from the beginning. But, since this was the first time I needed something like that and I guess nobody else ever needed it, I'll just close it and won't bother people. If someone ever needs to have this working, he/she can reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.