Bug 1001080 - Project explorer takes ages (if ever finishes) to initialize if the repo contains thousands of assets
Project explorer takes ages (if ever finishes) to initialize if the repo cont...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity urgent
: ER5
: 6.0.0
Assigned To: Alexandre Porcelli
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 09:03 EDT by Petr Široký
Modified: 2014-08-06 16:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Business central after ~40mins - project explorer is empty (47.58 KB, image/png)
2013-08-26 09:03 EDT, Petr Široký
no flags Details
VisualVM screenshot with memory/cpu usage (92.58 KB, image/png)
2013-08-26 09:05 EDT, Petr Široký
no flags Details

  None (edit)
Description Petr Široký 2013-08-26 09:03:26 EDT
Created attachment 790516 [details]
Business central after ~40mins - project explorer is empty

Description of problem:
Suppose there is a git repo that contains thousands of assets (~4k XLS tables). When the Project Explorer is opened the assets are _not_ shown even after ~40mins. Seems like they won't be ever shown as the cpu usage drops almost to zero after some time. The log does not contain any useful message/exception (actually there is not single message in the log, will try to run with DEBUG enabled).

Tried with 1,5GB heap and 2,5GB heap, does not seem to matter (although the memory is filling fast, see screenshot from visulvm).

Version-Release number of selected component (if applicable):
6.0.0-ER1


Steps to Reproduce:
1. Create repo with lots of assets (thousands of them).
2. Start up business central and Go to Project Explorer.


Actual results:
Project Explorer initialization is taking insane amount of time (more than 40 minutes) and might even not finish.

Expected results:
Even with huge repos the Project Explorer should load relatively fast - showing e.g. just first X assets of each kind (and possibility to show rest).
Comment 1 Petr Široký 2013-08-26 09:05:07 EDT
Created attachment 790517 [details]
VisualVM screenshot with memory/cpu usage
Comment 6 Alexandre Porcelli 2013-10-20 21:31:51 EDT
First set of performance improvements pushed into master and 0.3.x branches of Uberfire:

https://github.com/droolsjbpm/uberfire/commit/ff31e7bb
https://github.com/droolsjbpm/uberfire/commit/033f5992

Quick fix for new vfs update.

https://github.com/droolsjbpm/kie-wb-common/commit/dc0765e3
https://github.com/droolsjbpm/kie-wb-common/commit/19dc2617
Comment 7 Alexandre Porcelli 2013-10-21 08:55:04 EDT
Complemented with jgit version upgrade (that has several performance improvements) - pushed to master and 0.3.x of uberfire

https://github.com/droolsjbpm/uberfire/commit/7760dd05a
https://github.com/droolsjbpm/uberfire/commit/fe7e259b7
Comment 8 Petr Široký 2013-12-06 07:51:36 EST
I am marking this as verified because with ER5 the project explorer is initialized after about 30s, which is I think acceptable (at least in context of this BZ). In case other/similar perf. issues are found, new BZ(s) will be created.

Note You need to log in before you can comment on or make changes to this bug.