This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001091 - [engine-webadmin] help button of create new user window opens a new session to rhevm and not a help window
[engine-webadmin] help button of create new user window opens a new session t...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Kiril Nesenko
Pavel Stehlik
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 09:25 EDT by Elad
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 02:10:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log and screenshot (189.91 KB, application/x-gzip)
2013-08-26 09:25 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-08-26 09:25:31 EDT
Created attachment 790525 [details]
engine.log and screenshot

Description of problem:
When user tries to open a help window from 'add' new user window, help window does not appear. Instead, a new session to rhevm opens in a new browser tab. 

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.16.master.el6ev.noarch
rhevm-webadmin-portal-3.3.0-0.16.master.el6ev.noarch


How reproducible:
100%

Steps to Reproduce:
Under 'Users' tab, try to create a new user. In that window, click on help

Actual results:
help window does not appear. Instead, a new session to rhevm opens in a new browser tab

Expected results:
Help window should be open

Additional info: engine.log and screenshot
Comment 1 Einav Cohen 2013-08-27 17:45:34 EDT
I assume that DocumentationPath.csv is out of date, therefore the mapping between the dialog ID and the relevant documentation URL is incorrect.

@Cheryn - any thoughts? is there an eta for an up-to-date DocumentationPath.csv for rhevm-3.3?
Comment 2 Einav Cohen 2013-08-27 17:53:04 EDT
@Elad - out of curiosity: from the screen-shot that you have provided it seems that the RHEV branding isn't applied on your setup for some reason (i.e. your GUI looks like oVirt and not like RHEV-M). Any idea why? 
[IIUC, you have tested is11 (which should have the rhevm-branding RPM included and working properly)]
Comment 3 Elad 2013-08-27 19:29:54 EDT
(In reply to Einav Cohen from comment #2)
> @Elad - out of curiosity: from the screen-shot that you have provided it
> seems that the RHEV branding isn't applied on your setup for some reason
> (i.e. your GUI looks like oVirt and not like RHEV-M). Any idea why? 

No idea, this setup had been upgraded to the latest downstream build (IS11).
Comment 4 Cheryn Tan 2013-08-27 19:37:00 EDT
Hi Einav, taking a stab here, but it could be because rhevm-doc was not actually included in the is11 build? We've only just provided Kiril with the 3.3 doc packages on 23 Aug, for the beta (is12) build. 

Most of the paths for DocumentationPath.csv should still be current, I'll do a proper sweep-through closer to GA for any changes.
Comment 5 Itamar Heim 2013-08-28 02:10:28 EDT
closing for now. should be validated when the errata for docs is available, much closer to GA

Note You need to log in before you can comment on or make changes to this bug.