Bug 1001137 - missing Dependency for: ovirt-engine-notification-service
missing Dependency for: ovirt-engine-notification-service
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ovirt-engine (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 10:40 EDT by R P Herrold
Modified: 2013-10-18 08:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 08:28:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
long form package manifest (8.88 KB, text/plain)
2013-08-26 10:41 EDT, R P Herrold
no flags Details
short form package manifest (3.26 KB, text/plain)
2013-08-26 10:42 EDT, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2013-08-26 10:40:49 EDT
Description of problem:

F19, 64 bit, updated current

#  yum -y install ovirt-engine
eventually dies on a missing sub-dependency:
Version-Release number of selected component (if applicable):

--> Finished Dependency Resolution
Error: Package: ovirt-engine-notification-service-3.1.0-1.fc19.noarch (fedora)
           Requires: classpathx-mail
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 
 [root@precision380-64-kvm ~]# yum provides classpathx-mail
No matches found
[root@precision380-64-kvm ~]#

How reproducible:

Set up a basic machine in F19, 
run updates, 
selinux relabel
reboot
try to install ovirt-engine

Steps to Reproduce:

as above

Actual results:

failure message noted

Expected results:

a clean install

Additional info:

I will attach files enumerating the environment shortly
Comment 1 R P Herrold 2013-08-26 10:41:49 EDT
Created attachment 790550 [details]
long form package manifest
Comment 2 R P Herrold 2013-08-26 10:42:25 EDT
Created attachment 790552 [details]
short form package manifest
Comment 3 R P Herrold 2013-08-26 10:45:30 EDT
this means the oVirt engine is not presently installable and so is disabling as to further work
Comment 4 R P Herrold 2013-08-26 10:46:53 EDT
I was following the QuickStart guide at: http://www.ovirt.org/Quick_Start_Guide at step 4
Comment 5 Juan Hernández 2013-08-26 10:55:32 EDT
At the moment the ovirt-engine package from the Fedora official repositories doesn't work correctly, and there aren't plans to fix it in the immediate future.

If you want to test oVirt you should download and use the packages from the oVirt web site. If you are following the steps in the wiki you should have run the following command:

# yum localinstall http://ovirt.org/releases/ovirt-release-fedora.noarch.rpm

That should have created the file /etc/yum.repos.d/ovirt.repo which configures your machine to use the repositories from the oVirt web site, and then you should get version 3.2 running the following:

# yum install ovirt-engine

If that doesn't give you version 3.2 then something is wrong with the ovirt.repo file, please check it.

I would suggest to use the ovirt mailing list users@ovirt.org or the IRC #ovirt if you have further questions.
Comment 6 Juan Hernández 2013-10-18 08:28:36 EDT
Closed as the package has been retired.

Note You need to log in before you can comment on or make changes to this bug.