Bug 1001164 - Non-critical Resources in a Resource Group should not Prevent the Group from starting up
Non-critical Resources in a Resource Group should not Prevent the Group from ...
Status: CLOSED DUPLICATE of bug 1000626
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 11:07 EDT by Jesse Triplett
Modified: 2013-08-27 02:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 02:04:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Triplett 2013-08-26 11:07:59 EDT
1. Proposed title of this feature request

 Non-critical Resources in a Resource Group should not Prevent the Group from starting up


 2. What is the nature and description of the request?

 Rgmanager should not fail to start a resource group when a non critical resource is not available.


 3. Why does the you need this? (List the business requirements here)

 For expected behavior purposes. If a resource is marked as non-critical, it is not considered crucial to the service as a whole and allow the rest of the service to start up.


 4. How would you like to achieve this? (List the functional requirements here)

 Upon start up of a service, if the 'start' of a resource marked as non-critical fails to return '0', log the error and continue with the onlining of the other resources within the service. 


 5. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

 Perform test against service.


 6. Is there already an existing RFE upstream or in Red Hat Bugzilla?

 No


 7. Do you have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?

 Red Hat Enterprise Linux 6 


 8. Is the sales team involved in this request and do they have any additional input?

 No


 9. List any affected packages or components.

 rgmanager


 10. Would you be able to assist in testing this functionality if implemented?

 Yes
Comment 2 Jesse Triplett 2013-08-26 11:46:20 EDT
Hey all.  SFDC pulled a fast one on me and showed that I hadn't made a bz for this. So 1001164 and 1000626 are both opened for the same issue for the same case.  Let me know which one should be closed and I'll get it done. Thanks.

Sorry for the confusion,

Jesse Triplett, RHCE
Associate Technical Support Engineer
Red Hat Inc
Comment 3 Fabio Massimo Di Nitto 2013-08-27 02:04:20 EDT

*** This bug has been marked as a duplicate of bug 1000626 ***

Note You need to log in before you can comment on or make changes to this bug.