Bug 1001176 - switchyard apps containing " in name
switchyard apps containing " in name
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: JON (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity low
: ER3
: 6.0.0
Assigned To: kconner
Tomas Plevko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 11:36 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-08-26 11:36:34 EDT
Description of problem: If I deploy switchyard application it contains quotes within a resource name, for example "{urn:switchyard-quickstart:resteasy-binding:1.0}OrderService"

I consider it as a bug, because I haven't met this in any other JON plugin or resource.


Version-Release number of selected component (if applicable):
RHQ 4.9 master + switchyard plugin master
Comment 1 kconner 2013-08-29 10:27:07 EDT
I believe the quotes are being generated within the MBeanResourceDiscoveryComponent.  I'll take a look and see if there is any way to have them removed.
Comment 3 kconner 2013-09-18 16:01:00 EDT
The application names are now controlled directly through the JON plugin, rather than derived from the MBean components, and are available from tag 1.0.0-redhat-2 onwards
Comment 7 Tomas Plevko 2013-10-23 07:42:21 EDT
Verified. JON 3.2 ER3 + SOA6 ER4 + jon-plugin-pack-soa-3.2.0.ER3

Note You need to log in before you can comment on or make changes to this bug.