Bug 1001190 - alien fails with error message "Control file couldn't be read! at /usr/share/perl5/vendor_perl/Alien/Package/Deb.pm line 162"
alien fails with error message "Control file couldn't be read! at /usr/share/...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alien (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dmitrij S. Kryzhevich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 12:35 EDT by colin
Modified: 2016-03-08 13:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 06:08:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of yum package installation (53.77 KB, text/plain)
2013-08-27 08:50 EDT, colin
no flags Details

  None (edit)
Description colin 2013-08-26 12:35:27 EDT
Description of problem:

alien fails with error message
"Control file couldn't be read! at /usr/share/perl5/vendor_perl/Alien/Package/Deb.pm line 162."

Version-Release number of selected component (if applicable):
8.88

How reproducible:
Every time.

Steps to Reproduce:
1. ' alien -r CiscoPacketTracer-6.0.1-Ubuntu-no_tutorials.deb'
2.
3.

Actual results:
error messaage:
'Control file couldn't be read! at /usr/share/perl5/vendor_perl/Alien/Package/Deb.pm line 162.'

Expected results:
an rpm file should be produced.

Additional info:
Comment 1 Dmitrij S. Kryzhevich 2013-08-26 22:46:13 EDT
I'm busy right now and will be for a two weeks. Then - I'm here.

Please, could you provide link for this package? My alien-8.88-2.fc19.noarch provides no error on test cuneiform_1.1.0+dfsg-4_amd64.deb (https://launchpad.net/ubuntu/saucy/amd64/cuneiform/1.1.0+dfsg-4)
Comment 2 colin 2013-08-27 08:46:05 EDT
(In reply to Dmitrij S. Kryzhevich from comment #1)
> I'm busy right now and will be for a two weeks. Then - I'm here.

Excellent! :-)
 
> Please, could you provide link for this package? 

I am sorry - I am not entirely sure what you are asking here.
The alien package was freshly installed from F19 repositories using yum.
As it happens I kept a log of the installation using tee and so can post it here.
Comment 3 colin 2013-08-27 08:50:24 EDT
Created attachment 790966 [details]
log of yum package  installation

IIRC output captured by 
'yum install alien.noarch | tee yum_install_alien'
Comment 4 Orion Poplawski 2013-08-27 10:36:10 EDT
(In reply to colin from comment #2)
> (In reply to Dmitrij S. Kryzhevich from comment #1)
> > Please, could you provide link for this package? 
> 
> I am sorry - I am not entirely sure what you are asking here.

Where did you get CiscoPacketTracer-6.0.1-Ubuntu-no_tutorials.deb?
Comment 5 colin 2013-08-27 11:42:32 EDT
Packet Tracer is proprietary software provide by Cisco Ltd.

I am not able to provide a link as I have to login to my Cisco Networking Academy account to be able to download it.

Since their web service has undergone a revamp recently, and now seems to implemented by novice windows developers :-( I was attempting to investigate whether I could 'scratch my own itch' and provide a version that would install and run on Fedora by attempting to make use of their Ubuntu binary.

(I wrote a HowTo for the previous version here:
 http://forums.fedoraforum.org/showthread.php?t=275435)

Apparently even the Ubuntu installer wouldn't install unless you run this user-created script first:
http://kaslnetwork.com/articles/installing-cisco-packettracer-5-3-2-on-64-bit-ubuntu-or-debian/

If it helps at all you have to uncompress a file called:

'Cisco Packet Tracer 6.0.1 for Linux - Ubuntu installation (no tutorials)' 

Which I then renamed to remove unnecessary awkward characters.

I am sorry to be in the position of having called on your time due to the incompetent packaging of some proprietary software - but hey - it seems to be a worthwhile 'test case' in that it has provoked an error. ;-)
 
I could probably run some other tool, analyser or utility on the binary if you wanted - all suggestions gratefully received.
 
Once again thankyou for your attention - And I am quite happy to wait another fortnight or longer as necessary.
Comment 6 colin 2013-08-27 11:59:40 EDT
Further experimentation now shows a different result if the package name does not end with .deb 

[root@localhost yum]# alien -r /home/colin/Downloads/cisco/netacad.com/CiscoPacketTracer-6.0.1-Ubuntu-no_tutorials
Unknown type of package, /home/colin/Downloads/cisco/netacad.com/CiscoPacketTracer-6.0.1-Ubuntu-no_tutorials  

Which looks like a reasonable and indeed expected error to encounter if the file was not structured as expected for a .deb

Given that the error message that I originally reported could well actually be the result of the file not actually being a .deb - please do not feel the need to waste valuable developer time investigating a bug report that could ammount to
little more than 'unexpected program state caused by user ignorance' ;-)

Apologies for any inconvenience caused.
Comment 7 Dmitrij S. Kryzhevich 2013-09-06 14:54:50 EDT
You could execute:
# file <yourfile>
If you have a valid deb file the result would be something like this:

> $ file cuneiform_1.1.0+dfsg-4_amd64.deb
> cuneiform_1.1.0+dfsg-4_amd64.deb: Debian binary package (format 2.0)
Comment 8 Dmitrij S. Kryzhevich 2013-10-16 06:08:05 EDT
Looks like it should be closed.
Comment 9 Dheeraj Kumar 2016-03-08 13:18:05 EST
.deb file which you are using to convert into rpm is somehow missing something, you may try redownloading your deb file and try again.

This issue occurs only if your deb file has some issues.

Note You need to log in before you can comment on or make changes to this bug.