Bug 1001196 - gnome does not preserve settings from /etc/locale.conf
gnome does not preserve settings from /etc/locale.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 13:05 EDT by jcpunk
Modified: 2014-02-13 14:57 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040616 (view as bug list)
Environment:
Last Closed: 2014-02-13 14:57:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 709105 None None None Never

  None (edit)
Description jcpunk 2013-08-26 13:05:58 EDT
Description of problem:
When I login to gnome, my settings from /etc/locale.conf are not imported into my environment.

Version-Release number of selected component (if applicable):gnome-shell-3.8.4-2.fc19


How reproducible: 100%


Steps to Reproduce:
1.add LC_COLLATE="C" to /etc/locale.conf
2.login via ssh or vtty
3.note LC_COLLATE is set
4.login to gnome-shell
5.open terminal
6.note LC_COLLATE is not set

Actual results:
default settings are not honored

Expected results:
the defaults set in /etc/locale.conf should be honored

Additional info:
Comment 1 Jorge Fábregas 2013-09-14 09:35:32 EDT
I just bumped into this: installed Fedora 19, updated all packages, and the first thing I did was to change LANG=en_US.UTF-8 to LANG=en_US.iso88591 in /etc/locale.conf.  After rebooting the system, when I log into GNOME Shell with my regular user and execute "locale" I still see the old en_US.UTF-8.  I could change the locale thru my user's .bashrc but that would affect only the bash session.
Comment 2 Jorge Fábregas 2013-09-28 08:52:35 EDT
Hi,

Is there any update on this? A "can't reproduce", "wont fix in F19", "known issue" etc would be enough.

Thanks,
Jorge
Comment 3 Marc 2013-12-28 20:11:30 EST
External Bug GNOME 709105 has been marked as resolved/fixed.

Note You need to log in before you can comment on or make changes to this bug.