Bug 1001200 - [abrt] git-cola-1.8.3-1.fc19: cmds.py:862:prepare:IndexError: list index out of range
Summary: [abrt] git-cola-1.8.3-1.fc19: cmds.py:862:prepare:IndexError: list index out ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git-cola
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a3847d0701279e066a1bf4e56fd...
: 951263 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-26 17:13 UTC by blachniom
Modified: 2013-09-22 23:57 UTC (History)
5 users (show)

Fixed In Version: git-cola-1.8.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-12 02:02:40 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (532 bytes, text/plain)
2013-08-26 17:13 UTC, blachniom
no flags Details
File: environ (1.63 KB, text/plain)
2013-08-26 17:13 UTC, blachniom
no flags Details

Description blachniom 2013-08-26 17:13:14 UTC
Description of problem:
No clue, didn't notice.

Version-Release number of selected component:
git-cola-1.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /bin/git-cola --prompt
executable:     /bin/git-cola
kernel:         3.10.7-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
cmds.py:862:prepare:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/share/git-cola/lib/cola/cmds.py", line 1246, in run
    self.runner.run()
  File "/usr/share/git-cola/lib/cola/cmds.py", line 1228, in run
    self.cmd.prepare()
  File "/usr/share/git-cola/lib/cola/cmds.py", line 862, in prepare
    self.new_diff_text = self.diff_text_for(filenames[0])
IndexError: list index out of range

Local variables in innermost frame:
self: <cola.cmds.ShowUntracked object at 0x1bece90>
filenames: []

Comment 1 blachniom 2013-08-26 17:13:17 UTC
Created attachment 790609 [details]
File: backtrace

Comment 2 blachniom 2013-08-26 17:13:22 UTC
Created attachment 790610 [details]
File: environ

Comment 3 David Aguilar 2013-08-29 05:05:51 UTC
Thanks.  I've committed a guard against this condition.  v1.8.4 will be released later this week.

Comment 4 Christopher Meng 2013-09-05 23:13:01 UTC
*** Bug 951263 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2013-09-05 23:29:23 UTC
git-cola-1.8.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-cola-1.8.4-1.fc18

Comment 6 Fedora Update System 2013-09-05 23:30:44 UTC
git-cola-1.8.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/git-cola-1.8.4-1.fc19

Comment 7 Fedora Update System 2013-09-05 23:31:52 UTC
git-cola-1.8.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/git-cola-1.8.4-1.fc20

Comment 8 Fedora Update System 2013-09-06 17:26:06 UTC
Package git-cola-1.8.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-cola-1.8.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15961/git-cola-1.8.4-1.fc20
then log in and leave karma (feedback).

Comment 9 blachniom 2013-09-07 07:58:02 UTC
Thank you. I'm sure it's fine now, but as I stated above, i didn't catch the moment of the bug occuring, so can't really reproduce it.
Anyway, I think it would be better not to close the bug right away and wait a while. If no more comments are made within a week or so - close it.
Thanks again

Comment 10 Fedora Update System 2013-09-12 02:02:40 UTC
git-cola-1.8.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-09-16 00:29:37 UTC
git-cola-1.8.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-09-22 23:57:12 UTC
git-cola-1.8.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.