Bug 1001207 - cluster/stripe: make coalesce mode the default
cluster/stripe: make coalesce mode the default
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Foster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 14:06 EDT by Brian Foster
Modified: 2014-04-17 07:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:46:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Foster 2013-08-26 14:06:33 EDT
stripe/coalesce mode has been available for quite some time, enough to get any major issues shaken out. Make coalesce mode enabled by default for striped volumes.
Comment 1 Anand Avati 2013-08-26 14:08:10 EDT
REVIEW: http://review.gluster.org/5624 (cluster/stripe: enable coalesce mode by default) posted (#2) for review on master by Brian Foster (bfoster@redhat.com)
Comment 2 Anand Avati 2013-08-26 14:11:27 EDT
REVIEW: http://review.gluster.org/5624 (cluster/stripe: enable coalesce mode by default) posted (#3) for review on master by Brian Foster (bfoster@redhat.com)
Comment 3 Anand Avati 2013-08-29 00:33:47 EDT
COMMIT: http://review.gluster.org/5624 committed in master by Anand Avati (avati@redhat.com) 
------
commit bf63e7c6a3fa1bfceb14acf5504b0d52833f7118
Author: Brian Foster <bfoster@redhat.com>
Date:   Wed Aug 14 07:09:52 2013 -0400

    cluster/stripe: enable coalesce mode by default
    
    It has been available for a while now and is probably the sane
    default due to the more efficient layout and performance benefit.
    
    BUG: 1001207
    Change-Id: I6275f9741866c0afd6e685f8dc5867a86485fd20
    Signed-off-by: Brian Foster <bfoster@redhat.com>
    Reviewed-on: http://review.gluster.org/5624
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 Niels de Vos 2014-04-17 07:46:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.